# CVE-2024-23493: Team associated AD/LDAP Groups Leaked due to missing authorization

> An attacker can read AD/LDAP group details for teams they do not belong to due to missing authorization checks in Mattermost.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** BIT-mattermost-2024-23493, GHSA-7v3v-984v-h74r, GO-2024-2590

## What is CVE-2024-23493?

CVE-2024-23493 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Mattermost fails to properly authorize the requests fetching team associated AD/LDAP groups, allowing a user to fetch details of AD/LDAP groups of a team that they are not a member of.

Weakness: CWE-862 (Missing Authorization), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2024-23493?

11 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, mattermost and github.com/mattermost/mattermost-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost/server/v8` | Go | All versions | None |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.2.0 | 9.2.5 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.2.0 | 9.2.5 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.3.0 | 9.3.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.3.0 | 9.3.1 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.4.0 | 9.4.2 |
| `github.com/mattermost/mattermost/server/v8` | Go | From 9.4.0 | 9.4.2 |
| `mattermost` | Bitnami | All versions to 9.3.0-rc1 | 8.1.9, 9.2.5, 9.4.2 |
| `github.com/mattermost/mattermost-server` | Go | From 9.2.0+incompatible | 9.2.5+incompatible, 9.3.1+incompatible, 9.4.2+incompatible |
| `github.com/mattermost/mattermost-server/v5` | Go | All versions | None |
| `github.com/mattermost/mattermost-server/v6` | Go | All versions | None |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2024-23493?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 9.2.5, 9.3.1 or 9.4.2.

## Is CVE-2024-23493 being exploited?

There is no known exploitation of CVE-2024-23493 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23493 and fix it if it is affected.

What it is: CVE-2024-23493 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 29 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23493 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost/server/v8 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.2.0; fixed in 9.2.5
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.2.0; fixed in 9.2.5
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.3.0; fixed in 9.3.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.3.0; fixed in 9.3.1
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.4.0; fixed in 9.4.2
- github.com/mattermost/mattermost/server/v8 (Go): affected from 9.4.0; fixed in 9.4.2
- mattermost (Bitnami): affected all versions up to 9.3.0-rc1; fixed in 8.1.9, 9.2.5, 9.4.2
- github.com/mattermost/mattermost-server (Go): affected from 9.2.0+incompatible; fixed in 9.2.5+incompatible, 9.3.1+incompatible, 9.4.2+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): affected all versions; no fix listed
- github.com/mattermost/mattermost-server/v6 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23493/ (Markdown: https://insights.sbomify.com/CVE-2024-23493/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23493
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23493
- OSV: https://osv.dev/vulnerability/CVE-2024-23493

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23493/
Summaries are generated and may contain mistakes; the official description above is the record.
