# CVE-2024-2352: 1Panel swap baseApi.UpdateDeviceSwap command injection

> Remote attackers with permissions can execute arbitrary commands via the swap update API in 1Panel, requiring a patch.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Mar 2024
- **Updated:** 12 Aug 2024
- **Also known as:** GHSA-x2vg-5wrf-vj6v, GO-2024-2636

## What is CVE-2024-2352?

CVE-2024-2352 is a medium-severity command injection vulnerability in 1Panel, published on 10 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in 1Panel up to 1.10.1-lts. Affected by this issue is the function baseApi.UpdateDeviceSwap of the file /api/v1/toolbox/device/update/swap. The manipulation of the argument Path with the input 123123123\nopen -a Calculator leads to command injection. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. It is recommended to apply a patch to fix this issue. The identifier of this vulnerability is VDB-256304.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2024-2352?

3 open source packages ship an affected version, including github.com/1Panel-dev/1Panel. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.10.1-lts |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.10.1-lts |
| `github.com/1Panel-dev/1Panel` | Go | All versions | 1.10.1-lts |

Products: Fit2cloud 1panel.

## How do I fix CVE-2024-2352?

Upgrade github.com/1Panel-dev/1Panel to 1.10.1-lts or later.

## Is CVE-2024-2352 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2352 exists.

## Other vulnerabilities in 1Panel

- [CVE-2024-39911](https://insights.sbomify.com/CVE-2024-39911/): 1Panel SQL injection (critical 10.0)
- [CVE-2024-39907](https://insights.sbomify.com/CVE-2024-39907/): a sqlinjection in 1Panel (critical 9.8)
- [CVE-2025-56413](https://insights.sbomify.com/CVE-2025-56413/): Command injection in n/a (high 8.8)
- [CVE-2025-54424](https://insights.sbomify.com/CVE-2025-54424/): 1Panel Agent Bypasses Certificate Verification Leading to Arbitrary Command Execution (high 8.1)
- [CVE-2025-66507](https://insights.sbomify.com/CVE-2025-66507/): 1Panel – CAPTCHA Bypass via Client-Controlled Flag (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-2352 and fix it if it is affected.

What it is: CVE-2024-2352 is a medium-severity command injection vulnerability in 1Panel, published on 10 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2352 exists.

Affected packages and fixed versions:
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.10.1-lts
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.10.1-lts
- github.com/1Panel-dev/1Panel (Go): affected all versions; fixed in 1.10.1-lts

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-2352/ (Markdown: https://insights.sbomify.com/CVE-2024-2352/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-2352
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-2352
- OSV: https://osv.dev/vulnerability/CVE-2024-2352

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-2352/
Summaries are generated and may contain mistakes; the official description above is the record.
