CVE-2024-23537 Privilege escalation in Apache Fineract

High 8.4 Published Updated

Attackers can escalate privileges to any role without specific permissions, compromising the security of the financial platform.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-23537?

CVE-2024-23537 is a high-severity vulnerability in Apache Fineract, published on 29 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Privilege Management vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5.

Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Weakness: CWE-269

Which versions are affected by CVE-2024-23537?

It affects 1 product.

Products include Apache Fineract.

How do I fix CVE-2024-23537?

No fix has been published for CVE-2024-23537 yet. Limit exposure of the affected software until one is available.

Is CVE-2024-23537 being exploited?

There is no known exploitation of CVE-2024-23537 in the wild and no public exploit code.

Sources

Also known as GHSA-xcvp-xvv5-6298.

Is CVE-2024-23537 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free