# CVE-2024-23537: Privilege escalation in Apache Fineract

> Attackers can escalate privileges to any role without specific permissions, compromising the security of the financial platform.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Mar 2024
- **Updated:** 13 Feb 2025
- **Also known as:** GHSA-xcvp-xvv5-6298

## What is CVE-2024-23537?

CVE-2024-23537 is a high-severity vulnerability in Apache Fineract, published on 29 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Improper Privilege Management vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5.

Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2024-23537?

It affects 1 product.


Products: Apache Fineract.

## How do I fix CVE-2024-23537?

No fix has been published for CVE-2024-23537 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-23537 being exploited?

There is no known exploitation of CVE-2024-23537 in the wild and no public exploit code.

## Other vulnerabilities in Apache Fineract

- [CVE-2024-23538](https://insights.sbomify.com/CVE-2024-23538/): SQL injection in Apache Fineract (critical 9.9)
- [CVE-2018-11800](https://insights.sbomify.com/CVE-2018-11800/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2018-11801](https://insights.sbomify.com/CVE-2018-11801/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2018-1290](https://insights.sbomify.com/CVE-2018-1290/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2024-32838](https://insights.sbomify.com/CVE-2024-32838/): Apache Fineract: SQL injection vulnerabilities in offices API endpoint (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23537 and fix it if it is affected.

What it is: CVE-2024-23537 is a high-severity vulnerability in Apache Fineract, published on 29 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23537 in the wild and no public exploit code.

Affected product: Apache Fineract. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23537/ (Markdown: https://insights.sbomify.com/CVE-2024-23537/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23537
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23537
- OSV: https://osv.dev/vulnerability/CVE-2024-23537

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23537/
Summaries are generated and may contain mistakes; the official description above is the record.
