CVE-2024-23539 SQL injection in Apache Fineract

High 8.3 Published Updated

Attackers can manipulate database queries via the sqlSearch parameter in Apache Fineract, potentially reading or modifying data.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2024-23539?

CVE-2024-23539 is a high-severity SQL injection vulnerability in Apache Fineract, published on 29 Mar 2024. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Fineract.This issue affects Apache Fineract: <1.8.5.

Users are recommended to upgrade to version 1.8.5 or 1.9.0, which fix the issue.

Weakness: CWE-89

Which versions are affected by CVE-2024-23539?

It affects 1 product.

Products include Apache Fineract.

How do I fix CVE-2024-23539?

No fix has been published for CVE-2024-23539 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2024-23539 being exploited?

There is no known exploitation of CVE-2024-23539 in the wild and no public exploit code.

Sources

Also known as GHSA-p2vw-f9rr-2m2r.

Is CVE-2024-23539 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free