CVE-2024-23590 Apache Kylin: Session fixation in web interface
Critical 9.1
Published
Updated
Check this codebase for CVE-2024-23590 and fix it if it is affected.
What it is: CVE-2024-23590 is a critical vulnerability in Apache Kylin, published on 4 Nov 2024.
Exploitation: There is no known exploitation of CVE-2024-23590 in the wild and no public exploit code.
Affected packages and fixed versions:
- org.apache.kylin:kylin (Maven): affected from 2.0.0; fixed in 5.0.0
- org.apache.kylin:kylin (Maven): affected from 2.0.0; fixed in 5.0.0
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2024-23590/ (Markdown: https://insights.sbomify.com/CVE-2024-23590/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2024-23590?
CVE-2024-23590 is a critical vulnerability in Apache Kylin, published on 4 Nov 2024.
Official description
Session Fixation vulnerability in Apache Kylin.
This issue affects Apache Kylin: from 2.0.0 through 4.x.
Users are recommended to upgrade to version 5.0.0 or above, which fixes the issue.
Weakness: CWE-384
Which versions are affected by CVE-2024-23590?
2 open source packages ship an affected version, including org.apache.kylin:kylin. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.kylin:kylin Maven | From 2.0.0 | 5.0.0 |
org.apache.kylin:kylin Maven | From 2.0.0 | 5.0.0 |
Products include Apache Kylin.
How do I fix CVE-2024-23590?
Upgrade org.apache.kylin:kylin to 5.0.0 or later.
Is CVE-2024-23590 being exploited?
There is no known exploitation of CVE-2024-23590 in the wild and no public exploit code.
Other vulnerabilities in Apache Kylin
- CVE-2020-1956 Apache Kylin OS Command Injection
- CVE-2026-62390 Apache Kylin: SQL Injection Vulnerability in Catalog Cache Refresh API
- CVE-2022-44621 Apache Kylin: Command injection by Diagnosis Controller
- CVE-2022-24697 Apache Kylin vulnerable to remote code execution
- CVE-2021-31522 Apache Kylin unsafe class loading
Sources
Also known as GHSA-752q-72qc-rc66.