CVE-2024-23634 GeoServer arbitrary file renaming vulnerability in REST Coverage/Data Store API
Authenticated administrators can rename arbitrary files via the REST API, causing denial of service or security bypasses in GeoServer.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2024-23634?
CVE-2024-23634 is a medium-severity path traversal vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. An arbitrary file renaming vulnerability exists in versions prior to 2.23.5 and 2.24.2 that enables an authenticated administrator with permissions to modify stores through the REST Coverage Store or Data Store API to rename arbitrary files and directories with a name that does not end in `.zip`. Store file uploads rename zip files to have a `.zip` extension if it doesn't already have one before unzipping the file. This is fine for file and url upload methods where the files will be in a specific subdirectory of the data directory but, when using the external upload method, this allows arbitrary files and directories to be renamed. Renaming GeoServer files will most likely result in a denial of service, either completely preventing GeoServer from running or effectively deleting specific resources (such as a workspace, layer or style). In some cases, renaming GeoServer files could revert to the default settings for that file which could be relatively harmless like removing contact information or have more serious consequences like allowing users to make OGC requests that the customized settings would have prevented them from making. The impact of renaming non-GeoServer files depends on the specific environment although some sort of denial of service is a likely outcome. Versions 2.23.5 and 2.24.2 contain a fix for this issue.
Which versions are affected by CVE-2024-23634?
4 open source packages ship an affected version, including org.geoserver:gs-restconfig. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver:gs-restconfig Maven | All versions | 2.23.5 |
org.geoserver:gs-restconfig Maven | All versions | 2.23.5 |
org.geoserver:gs-restconfig Maven | From 2.24.0 | 2.24.2 |
org.geoserver:gs-restconfig Maven | From 2.24.0 | 2.24.2 |
Products include Geoserver Geoserver.
How do I fix CVE-2024-23634?
Upgrade org.geoserver:gs-restconfig to a fixed version for your release line: 2.23.5 or 2.24.2.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2024-23634 being exploited?
There is no known exploitation of CVE-2024-23634 in the wild and no public exploit code.
Other vulnerabilities in geoserver
- CVE-2024-36401 OSGeo GeoServer GeoTools Eval Injection
- CVE-2025-58360 OSGeo GeoServer Improper Restriction of XML External Entity Reference
- CVE-2023-35042 GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language
- CVE-2024-24749 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
- CVE-2023-41877 GeoServer log file path traversal vulnerability
Sources
Also known as GHSA-75m5-hh4r-q9gx.