{"answers":{"affected":"2 open source packages ship an affected version, including org.owasp.antisamy:antisamy. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23635 in the wild and no public exploit code.","fix":"Upgrade org.owasp.antisamy:antisamy to 1.7.5 or later.","what":"CVE-2024-23635 is a medium-severity cross-site scripting vulnerability in nahsra antisamy, published on 2 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23635 and fix it if it is affected.\n\nWhat it is: CVE-2024-23635 is a medium-severity cross-site scripting vulnerability in nahsra antisamy, published on 2 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-23635 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.5\n- org.owasp.antisamy:antisamy (Maven): affected all versions; fixed in 1.7.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23635/ (Markdown: https://insights.sbomify.com/CVE-2024-23635/index.md)","id":"CVE-2024-23635","markdown":"https://insights.sbomify.com/CVE-2024-23635/index.md","name":"CVE-2024-23635","record":{"aliases":["DEBIAN-CVE-2024-23635","GHSA-2mrq-w8pv-5pvq","UBUNTU-CVE-2024-23635"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"HTML sanitization library","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via mutation XSS in AntiSamy when comment preservation is enabled, requiring library upgrades.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"antisamy","vendor":"antisamy_project"}],"cvss":{"score":6.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to 1.7.5, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. Patched in AntiSamy 1.7.5 and later.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"AntiSamy malicious input can provoke XSS when preserving comments","id":"CVE-2024-23635","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":2,"n_references":1,"next":{"headline":"SOFARPC Remote Command Execution(RCE) Vulnerbility","id":"CVE-2024-23636"},"packages":[{"ecosystem":"Maven","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":null,"source":"GHSA-2mrq-w8pv-5pvq"},{"ecosystem":"Maven","fixed":["1.7.5"],"introduced":["0"],"last_affected":[],"package":"org.owasp.antisamy:antisamy","purl":"pkg:maven/org.owasp.antisamy/antisamy","source":"GHSA-2mrq-w8pv-5pvq"}],"prev":{"headline":"GeoServer arbitrary file renaming vulnerability in REST Coverage/Data Store API","id":"CVE-2024-23634"},"products":["antisamy"],"published":"2024-02-02","related":[{"cvss_score":7.5,"headline":"Denial of service in HtmlUnit-Neko","id":"CVE-2022-28366","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"mXSS in AntiSamy","id":"CVE-2023-43643","kev_date_added":null,"published":"2023-10-09"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-28367","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2022-29577","kev_date_added":null,"published":"2022-04-21"},{"cvss_score":6.1,"headline":"Cross-site Scripting in OWASP AntiSamy","id":"CVE-2021-35043","kev_date_added":null,"published":"2021-07-19"},{"cvss_score":6.1,"headline":"OWASP AntiSamy Cross-site Scripting vulnerability","id":"CVE-2017-14735","kev_date_added":null,"published":"2017-09-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["nahsra"]},"summary":"Attackers can execute arbitrary scripts via mutation XSS in AntiSamy when comment preservation is enabled, requiring library upgrades.","url":"https://insights.sbomify.com/CVE-2024-23635/"}