# CVE-2024-23637: OctoPrint Unverified Password Change via Access Control Settings

> Malicious admins can change other admin passwords without re-authentication, potentially locking out legitimate administrators from the OctoPrint instance.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 31 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-5626-pw9c-hmjr, PYSEC-2024-29

## What is CVE-2024-23637?

CVE-2024-23637 is a medium-severity missing authorization vulnerability in OctoPrint, published on 31 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

OctoPrint is a web interface for 3D printer.s OctoPrint versions up until and including 1.9.3 contain a vulnerability that allows malicious admins to change the password of other admin accounts, including their own, without having to repeat their password. An attacker who managed to hijack an admin account might use this to lock out actual admins from their OctoPrint instance. The vulnerability will be patched in version 1.10.0.

Weakness: CWE-620 (Unverified Password Change), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-23637?

3 open source packages ship an affected version, including octoprint and OctoPrint. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `octoprint` | PyPI | All versions | 1.10.0rc1 |
| `octoprint` | PyPI | All versions | 1.10.0rc1 |
| `OctoPrint` | PyPI | All versions | 1.10.0rc1 |

Products: Octoprint Octoprint.

## How do I fix CVE-2024-23637?

Upgrade octoprint to 1.10.0rc1 or later.

## Is CVE-2024-23637 being exploited?

There is no known exploitation of CVE-2024-23637 in the wild and no public exploit code.

## Other vulnerabilities in OctoPrint

- [CVE-2018-16710](https://insights.sbomify.com/CVE-2018-16710/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-58180](https://insights.sbomify.com/CVE-2025-58180/): OctoPrint is Vulnerable to RCE Attacks via Unsanitized Filename in File Upload (high 7.5)
- [CVE-2022-1430](https://insights.sbomify.com/CVE-2022-1430/): Cross-site Scripting (XSS) - DOM in octoprint/octoprint (high 7.5)
- [CVE-2022-1432](https://insights.sbomify.com/CVE-2022-1432/): Cross-site Scripting (XSS) - Generic in octoprint/octoprint (high 7.5)
- [CVE-2024-32977](https://insights.sbomify.com/CVE-2024-32977/): OctoPrint Authentication Bypass via X-Forwarded-For Header when autologinLocal is enabled (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23637 and fix it if it is affected.

What it is: CVE-2024-23637 is a medium-severity missing authorization vulnerability in OctoPrint, published on 31 Jan 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23637 in the wild and no public exploit code.

Affected packages and fixed versions:
- octoprint (PyPI): affected all versions; fixed in 1.10.0rc1
- octoprint (PyPI): affected all versions; fixed in 1.10.0rc1
- OctoPrint (PyPI): affected all versions; fixed in 1.10.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23637/ (Markdown: https://insights.sbomify.com/CVE-2024-23637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23637
- OSV: https://osv.dev/vulnerability/CVE-2024-23637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23637/
Summaries are generated and may contain mistakes; the official description above is the record.
