# CVE-2024-23638: SQUID-2023:11 Denial of Service in Cache Manager

> A trusted client can cause a denial of service in Squid proxy by exploiting an expired pointer reference in Cache Manager error responses.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** AZL-34001, CLSA-2024-1733142081, CLSA-2024-1733142094, CLSA-2024-1734542622, DEBIAN-CVE-2024-23638, GHSA-j49p-553x-48rx, OESA-2024-1124, ROOT-OS-ALPINE-318-CVE-2024-23638, UBUNTU-CVE-2024-23638

## What is CVE-2024-23638?

CVE-2024-23638 is a medium-severity use after free vulnerability in Squid-Cache Squid, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.

Weakness: CWE-672 (Operation on a Resource after Expiration or Release), CWE-825 (Expired Pointer Dereference)

## Which versions are affected by CVE-2024-23638?

It affects 1 product.


Products: Squid-Cache Squid.

## How do I fix CVE-2024-23638?

Upgrade to a fixed version.

## Is CVE-2024-23638 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23638 exists.

## Other vulnerabilities in Squid-Cache Squid

- [CVE-2025-62168](https://insights.sbomify.com/CVE-2025-62168/): Squid vulnerable to information disclosure via authentication credential leakage in error handling (critical 10.0)
- [CVE-2025-54574](https://insights.sbomify.com/CVE-2025-54574/): Squid's URN Handling can lead to Buffer Overflow (critical 9.3)
- [CVE-2026-33526](https://insights.sbomify.com/CVE-2026-33526/): Squid vulnerable to Denial of Service in ICP Request handling (critical 9.2)
- [CVE-2026-32748](https://insights.sbomify.com/CVE-2026-32748/): Squid has Denial of Service in ICP Response handling (high 8.7)
- [CVE-2023-50269](https://insights.sbomify.com/CVE-2023-50269/): SQUID-2023:10 Denial of Service in HTTP Request parsing (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23638 and fix it if it is affected.

What it is: CVE-2024-23638 is a medium-severity use after free vulnerability in Squid-Cache Squid, published on 23 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23638 exists.

Affected product: Squid-Cache Squid. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23638/ (Markdown: https://insights.sbomify.com/CVE-2024-23638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23638
- OSV: https://osv.dev/vulnerability/CVE-2024-23638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23638/
Summaries are generated and may contain mistakes; the official description above is the record.
