# CVE-2024-23639: micronaut-core management endpoints vulnerable to drive-by localhost attack

> Attackers can exploit unsecured management endpoints via drive-by localhost attacks to access sensitive data or bypass security controls in development environments.

- **Severity:** Medium 5.1 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 9 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-583g-g682-crxf

## What is CVE-2024-23639?

CVE-2024-23639 is a medium-severity server-side request forgery vulnerability in micronaut-projects micronaut-core, published on 9 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Micronaut Framework is a modern, JVM-based, full stack Java framework designed for building modular, easily testable JVM applications with support for Java, Kotlin and the Groovy language. Enabled but unsecured management endpoints are susceptible to drive-by localhost attacks. While not typical of a production application, these attacks may have more impact on a development environment where such endpoints may be flipped on without much thought. A malicious/compromised website can make HTTP requests to `localhost`. Normally, such requests would trigger a CORS preflight check which would prevent the request; however, some requests are "simple" and do not require a preflight check. These endpoints, if enabled and not secured, are vulnerable to being triggered. Production environments typically disable unused endpoints and secure/restrict access to needed endpoints. A more likely victim is the developer in their local development host, who has enabled endpoints without security for the sake of easing development. This issue has been addressed in version 3.8.3. Users are advised to upgrade.

Weakness: CWE-664 (Improper Control of a Resource Through its Lifetime), CWE-610 (Externally Controlled Reference to a Resource in Another Sphere), CWE-15 (External Control of System or Configuration Setting)

## Which versions are affected by CVE-2024-23639?

6 open source packages ship an affected version, including io.micronaut:micronaut-http-server, io.micronaut:micronaut-http-server-netty and io.micronaut:micronaut-http-server-tck. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.micronaut:micronaut-http-server` | Maven | All versions | 3.8.3 |
| `io.micronaut:micronaut-http-server` | Maven | All versions | 3.8.3 |
| `io.micronaut:micronaut-http-server-netty` | Maven | All versions | 3.8.3 |
| `io.micronaut:micronaut-http-server-netty` | Maven | All versions | 3.8.3 |
| `io.micronaut:micronaut-http-server-tck` | Maven | All versions | 3.8.3 |
| `io.micronaut:micronaut-http-server-tck` | Maven | All versions | 3.8.3 |

Products: Objectcomputing Micronaut.

## How do I fix CVE-2024-23639?

Upgrade io.micronaut:micronaut-http-server to 3.8.3 or later.

## Is CVE-2024-23639 being exploited?

There is no known exploitation of CVE-2024-23639 in the wild and no public exploit code.

## Other vulnerabilities in micronaut-projects micronaut-core

- [CVE-2020-7611](https://insights.sbomify.com/CVE-2020-7611/): Micronaut's HTTP client is vulnerable to HTTP Request Header Injection (critical 9.8)
- [CVE-2026-33013](https://insights.sbomify.com/CVE-2026-33013/): Micronaut vulnerable to DoS via crafted form-urlencoded body binding with descending array indices (high 8.2)
- [CVE-2026-33012](https://insights.sbomify.com/CVE-2026-33012/): Micronaut Framework vulnerable to a Denial of Service in HTML error response caching (high 7.5)
- [CVE-2021-32769](https://insights.sbomify.com/CVE-2021-32769/): Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in micronaut-core (high 7.5)
- [CVE-2022-21700](https://insights.sbomify.com/CVE-2022-21700/): Memory leak in micronaut-core (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23639 and fix it if it is affected.

What it is: CVE-2024-23639 is a medium-severity server-side request forgery vulnerability in micronaut-projects micronaut-core, published on 9 Feb 2024. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23639 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.micronaut:micronaut-http-server (Maven): affected all versions; fixed in 3.8.3
- io.micronaut:micronaut-http-server (Maven): affected all versions; fixed in 3.8.3
- io.micronaut:micronaut-http-server-netty (Maven): affected all versions; fixed in 3.8.3
- io.micronaut:micronaut-http-server-netty (Maven): affected all versions; fixed in 3.8.3
- io.micronaut:micronaut-http-server-tck (Maven): affected all versions; fixed in 3.8.3
- io.micronaut:micronaut-http-server-tck (Maven): affected all versions; fixed in 3.8.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23639/ (Markdown: https://insights.sbomify.com/CVE-2024-23639/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23639
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23639
- OSV: https://osv.dev/vulnerability/CVE-2024-23639

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23639/
Summaries are generated and may contain mistakes; the official description above is the record.
