{"answers":{"affected":"8 open source packages ship an affected version, including @sveltejs/kit and @sveltejs/adapter-node. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23641 exists.","fix":"Upgrade @sveltejs/kit to 2.4.3 or later.","what":"CVE-2024-23641 is a high-severity denial of service vulnerability in sveltejs kit, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23641 and fix it if it is affected.\n\nWhat it is: CVE-2024-23641 is a high-severity denial of service vulnerability in sveltejs kit, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23641 exists.\n\nAffected packages and fixed versions:\n- @sveltejs/kit (npm): affected from 2.0.0; fixed in 2.4.3\n- @sveltejs/kit (npm): affected from 2.0.0; fixed in 2.4.3\n- @sveltejs/adapter-node (npm): affected from 2.0.0; fixed in 2.1.2\n- @sveltejs/adapter-node (npm): affected from 2.0.0; fixed in 2.1.2\n- @sveltejs/adapter-node (npm): affected from 3.0.0; fixed in 3.0.3\n- @sveltejs/adapter-node (npm): affected from 3.0.0; fixed in 3.0.3\n- @sveltejs/adapter-node (npm): affected from 4.0.0; fixed in 4.0.1\n- @sveltejs/adapter-node (npm): affected from 4.0.0; fixed in 4.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23641/ (Markdown: https://insights.sbomify.com/CVE-2024-23641/index.md)","id":"CVE-2024-23641","markdown":"https://insights.sbomify.com/CVE-2024-23641/index.md","name":"CVE-2024-23641","record":{"aliases":["GHSA-g5m6-hxpp-fc49"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"SvelteKit web framework","requires_auth":"none","summary":"Attackers can crash SvelteKit 2 applications by sending GET or HEAD requests with a body, requiring manual restarts to restore service.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"adapter-node","vendor":"svelte"},{"product":"kit","vendor":"svelte"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"SvelteKit is a web development kit. In SvelteKit 2, sending a GET request with a body eg `{}` to a built and previewed/hosted sveltekit app throws `Request with GET/HEAD method cannot have body.` and crashes the preview/hosting. After this happens, one must manually restart the app. `TRACE` requests will also cause the app to crash. Prerendered pages and SvelteKit 1 apps are not affected. `@sveltejs/adapter-node` versions 2.1.2, 3.0.3, and 4.0.1 and `@sveltejs/kit` version 2.4.3 contain a patch for this issue.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Sending a GET or HEAD request with a body crashes SvelteKit","id":"CVE-2024-23641","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2024"},"n_packages":8,"n_references":2,"next":{"headline":"GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Simple SVG Renderer","id":"CVE-2024-23642"},"packages":[{"ecosystem":"npm","fixed":["2.1.2"],"introduced":["2.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":null,"source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["2.1.2"],"introduced":["2.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":"pkg:npm/%40sveltejs/adapter-node","source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":null,"source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["3.0.3"],"introduced":["3.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":"pkg:npm/%40sveltejs/adapter-node","source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":null,"source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["4.0.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@sveltejs/adapter-node","purl":"pkg:npm/%40sveltejs/adapter-node","source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["2.4.3"],"introduced":["2.0.0"],"last_affected":[],"package":"@sveltejs/kit","purl":null,"source":"GHSA-g5m6-hxpp-fc49"},{"ecosystem":"npm","fixed":["2.4.3"],"introduced":["2.0.0"],"last_affected":[],"package":"@sveltejs/kit","purl":"pkg:npm/%40sveltejs/kit","source":"GHSA-g5m6-hxpp-fc49"}],"prev":{"headline":"GeoServer Stored Cross-Site Scripting (XSS) vulnerability in Style Publisher","id":"CVE-2024-23640"},"products":["kit"],"published":"2024-01-24","related":[{"cvss_score":8.4,"headline":"SvelteKit Denial of service and possible SSRF when using prerendering","id":"CVE-2025-67647","kev_date_added":null,"published":"2026-01-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-11-13","vendors":["sveltejs"]},"summary":"Attackers can crash SvelteKit 2 applications by sending GET or HEAD requests with a body, requiring manual restarts to restore service.","url":"https://insights.sbomify.com/CVE-2024-23641/"}