CVE-2024-23643 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in GWC Seed Form
An authenticated administrator can inject JavaScript into the GeoServer catalog, leading to script execution in another administrator's browser via the GWC Seed Form.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-23643?
CVE-2024-23643 is a medium-severity cross-site scripting vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.2 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another administrator’s browser when viewed in the GWC Seed Form. Access to the GWC Seed Form is limited to full administrators by default and granting non-administrators access to this endpoint is not recommended. Versions 2.23.2 and 2.24.1 contain a fix for this issue.
Weakness: CWE-79
Which versions are affected by CVE-2024-23643?
4 open source packages ship an affected version, including org.geoserver:gs-gwc-rest. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.geoserver:gs-gwc-rest Maven | All versions | 2.23.2 |
org.geoserver:gs-gwc-rest Maven | All versions | 2.23.2 |
org.geoserver:gs-gwc-rest Maven | From 2.24.0 | 2.24.1 |
org.geoserver:gs-gwc-rest Maven | From 2.24.0 | 2.24.1 |
Products include Geoserver Geoserver.
How do I fix CVE-2024-23643?
Upgrade org.geoserver:gs-gwc-rest to a fixed version for your release line: 2.23.2 or 2.24.1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2024-23643 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23643 exists.
Other vulnerabilities in geoserver
- CVE-2024-36401 OSGeo GeoServer GeoTools Eval Injection
- CVE-2025-58360 OSGeo GeoServer Improper Restriction of XML External Entity Reference
- CVE-2023-35042 GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language
- CVE-2024-24749 Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat
- CVE-2023-41877 GeoServer log file path traversal vulnerability
Sources
Also known as GHSA-56r3-f536-5gf7.