# CVE-2024-23644: trillium-http and trillium-client vulnerable to HTTP Request/Response Splitting

> Attackers can inject CRLF sequences into HTTP headers to split requests or responses, potentially leading to data exfiltration or SSRF.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-9f9p-cp3c-72jf, RUSTSEC-2024-0008, RUSTSEC-2024-0009

## What is CVE-2024-23644?

CVE-2024-23644 is a medium-severity vulnerability in trillium-rs trillium, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Trillium is a composable toolkit for building internet applications with async rust. In `trillium-http` prior to 0.3.12 and `trillium-client` prior to 0.5.4, insufficient validation of outbound header values may lead to request splitting or response splitting attacks in scenarios where attackers have sufficient control over headers. This only affects use cases where attackers have control of request headers, and can insert "\r\n" sequences. Specifically, if untrusted and unvalidated input is inserted into header names or values.

Outbound `trillium_http::HeaderValue` and `trillium_http::HeaderName` can be constructed infallibly and were not checked for illegal bytes when sending requests from the client or responses from the server. Thus, if an attacker has sufficient control over header values (or names) in a request or response that they could inject `\r\n` sequences, they could get the client and server out of sync, and then pivot to gain control over other parts of requests or responses. (i.e. exfiltrating data from other requests, SSRF, etc.)

In `trillium-http` versions 0.3.12 and later, if a header name is invalid in server response headers, the specific header and any associated values are omitted from network transmission. Additionally, if a header value is invalid in server response headers, the individual header value is omitted from network transmission. Other headers values with the same header name will still be sent. In `trillium-client` versions 0.5.4 and later, if any header name or header value is invalid in the client request headers, awaiting the client Conn returns an `Error::MalformedHeader` prior to any network access. As a workaround, Trillium services and client applications should sanitize or validate untrusted input that is included in header values and header names. Carriage return, newline, and null characters are not allowed.

Weakness: CWE-436 (Interpretation Conflict), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2024-23644?

6 open source packages ship an affected version, including trillium-client and trillium-http. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trillium-client` | crates.io | All versions | 0.5.4 |
| `trillium-client` | crates.io | All versions | 0.5.4 |
| `trillium-client` | crates.io | From 0.0.0-0 | 0.5.4 |
| `trillium-http` | crates.io | All versions | 0.3.12 |
| `trillium-http` | crates.io | All versions | 0.3.12 |
| `trillium-http` | crates.io | From 0.0.0-0 | 0.3.12 |

Products: Trillium Trillium, Trillium Trillium-Http.

## How do I fix CVE-2024-23644?

Upgrade trillium-client to 0.5.4 or later.

## Is CVE-2024-23644 being exploited?

There is no known exploitation of CVE-2024-23644 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23644 and fix it if it is affected.

What it is: CVE-2024-23644 is a medium-severity vulnerability in trillium-rs trillium, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23644 in the wild and no public exploit code.

Affected packages and fixed versions:
- trillium-client (crates.io): affected all versions; fixed in 0.5.4
- trillium-client (crates.io): affected all versions; fixed in 0.5.4
- trillium-client (crates.io): affected from 0.0.0-0; fixed in 0.5.4
- trillium-http (crates.io): affected all versions; fixed in 0.3.12
- trillium-http (crates.io): affected all versions; fixed in 0.3.12
- trillium-http (crates.io): affected from 0.0.0-0; fixed in 0.3.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23644/ (Markdown: https://insights.sbomify.com/CVE-2024-23644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23644
- OSV: https://osv.dev/vulnerability/CVE-2024-23644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23644/
Summaries are generated and may contain mistakes; the official description above is the record.
