{"answers":{"affected":"2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23646 exists.","fix":"Upgrade pimcore/admin-ui-classic-bundle to 1.3.2 or later.","what":"CVE-2024-23646 is a high-severity SQL injection vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23646 and fix it if it is affected.\n\nWhat it is: CVE-2024-23646 is a high-severity SQL injection vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23646 exists.\n\nAffected packages and fixed versions:\n- pimcore/admin-ui-classic-bundle (Packagist): affected from 1.0.0; fixed in 1.3.2\n- pimcore/admin-ui-classic-bundle (Packagist): affected from 1.0.0; fixed in 1.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23646/ (Markdown: https://insights.sbomify.com/CVE-2024-23646/index.md)","id":"CVE-2024-23646","markdown":"https://insights.sbomify.com/CVE-2024-23646/index.md","name":"CVE-2024-23646","record":{"aliases":["GHSA-cwx6-4wmf-c6xv"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Pimcore Admin Bundle","requires_auth":"low_privilege","summary":"A SQL injection vulnerability in Pimcore Admin Classic Bundle allows backend users to execute arbitrary SQL, modify data, and escalate privileges to admin level.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"admin_classic_bundle","vendor":"pimcore"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. The application allows users to create zip files from available files on the site. In the 1.x branch prior to version 1.3.2, parameter `selectedIds` is susceptible to SQL Injection. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. Version 1.3.2 contains a fix for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"sql_injection","year":"2024"},"n_packages":2,"n_references":5,"next":{"headline":"PKCE downgrade attack in Authentik","id":"CVE-2024-23647"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["1.0.0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":null,"source":"GHSA-cwx6-4wmf-c6xv"},{"ecosystem":"Packagist","fixed":["1.3.2"],"introduced":["1.0.0"],"last_affected":[],"package":"pimcore/admin-ui-classic-bundle","purl":"pkg:composer/pimcore/admin-ui-classic-bundle","source":"GHSA-cwx6-4wmf-c6xv"}],"prev":{"headline":"GLPI reflected XSS in reports pages","id":"CVE-2024-23645"},"products":["admin-ui-classic-bundle"],"published":"2024-01-24","related":[{"cvss_score":8.8,"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648","kev_date_added":null,"published":"2024-01-24"},{"cvss_score":8.5,"headline":"Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls","id":"CVE-2023-49075","kev_date_added":null,"published":"2023-11-28"},{"cvss_score":8.1,"headline":"Pimcore Host Header Injection in user invitation link","id":"CVE-2024-25625","kev_date_added":null,"published":"2024-02-19"},{"cvss_score":6.9,"headline":"Pimcore Admin Classic Bundle allows user enumeration","id":"CVE-2025-24980","kev_date_added":null,"published":"2025-02-07"},{"cvss_score":6.5,"headline":"Pimcore Admin Classic Bundle permissions are not getting checked when working with tags","id":"CVE-2024-24822","kev_date_added":null,"published":"2024-02-07"},{"cvss_score":6.3,"headline":"Pimcore vulnerable to disclosure of system and database information behind /admin firewall","id":"CVE-2024-41109","kev_date_added":null,"published":"2024-07-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["pimcore"]},"summary":"A SQL injection vulnerability in Pimcore Admin Classic Bundle allows backend users to execute arbitrary SQL, modify data, and escalate privileges to admin level.","url":"https://insights.sbomify.com/CVE-2024-23646/"}