# CVE-2024-23646: Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip

> A SQL injection vulnerability in Pimcore Admin Classic Bundle allows backend users to execute arbitrary SQL, modify data, and escalate privileges to admin level.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-cwx6-4wmf-c6xv

## What is CVE-2024-23646?

CVE-2024-23646 is a high-severity SQL injection vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. The application allows users to create zip files from available files on the site. In the 1.x branch prior to version 1.3.2, parameter `selectedIds` is susceptible to SQL Injection. Any backend user with very basic permissions can execute arbitrary SQL statements and thus alter any data or escalate their privileges to at least admin level. Version 1.3.2 contains a fix for this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2024-23646?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 1.0.0 | 1.3.2 |
| `pimcore/admin-ui-classic-bundle` | Packagist | From 1.0.0 | 1.3.2 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2024-23646?

Upgrade pimcore/admin-ui-classic-bundle to 1.3.2 or later.

## Is CVE-2024-23646 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23646 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23648](https://insights.sbomify.com/CVE-2024-23648/): Pimcore Admin Classic Bundle host header injection in the password reset (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)
- [CVE-2024-24822](https://insights.sbomify.com/CVE-2024-24822/): Pimcore Admin Classic Bundle permissions are not getting checked when working with tags (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23646 and fix it if it is affected.

What it is: CVE-2024-23646 is a high-severity SQL injection vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23646 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected from 1.0.0; fixed in 1.3.2
- pimcore/admin-ui-classic-bundle (Packagist): affected from 1.0.0; fixed in 1.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23646/ (Markdown: https://insights.sbomify.com/CVE-2024-23646/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23646
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23646
- OSV: https://osv.dev/vulnerability/CVE-2024-23646

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23646/
Summaries are generated and may contain mistakes; the official description above is the record.
