CVE-2024-23647 PKCE downgrade attack in Authentik
Attackers can bypass PKCE protection in Authentik by omitting the code_challenge parameter, enabling CSRF and code injection attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2024-23647?
CVE-2024-23647 is a medium-severity vulnerability in goauthentik authentik, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks. Versions 2023.8.7 and 2023.10.7 fix the issue.
Weakness: CWE-287
Which versions are affected by CVE-2024-23647?
6 open source packages ship an affected version, including goauthentik.io and authentik. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
goauthentik.io Go | All versions | None |
goauthentik.io Go | All versions | 2023.8.7 |
goauthentik.io Go | All versions | 2023.8.7 |
goauthentik.io Go | From 2023.10.0 | 2023.10.7 |
goauthentik.io Go | From 2023.10.0 | 2023.10.7 |
authentik Bitnami | All versions | 2023.8.7, 2023.10.7 |
Products include Goauthentik Authentik.
How do I fix CVE-2024-23647?
Upgrade goauthentik.io to a fixed version for your release line: 2023.8.7 or 2023.10.7.
Is CVE-2024-23647 being exploited?
There is no known exploitation of CVE-2024-23647 in the wild and no public exploit code.
Other vulnerabilities in goauthentik authentik
- CVE-2026-49448 authentik: SourceStage bypass via empty POST
- CVE-2023-46249 authentik potential installation takeover when default admin user is deleted
- CVE-2022-23555 authentik vulnerable to Improper Authentication via invitation URL token reuse
- CVE-2026-42849 authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover
- CVE-2026-25227 authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint
Sources
Also known as BIT-authentik-2024-23647, GHSA-mrx3-gxjx-hjqj, GO-2024-2479.