{"answers":{"affected":"6 open source packages ship an affected version, including goauthentik.io and authentik. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23647 in the wild and no public exploit code.","fix":"Upgrade goauthentik.io to a fixed version for your release line: 2023.8.7 or 2023.10.7.","what":"CVE-2024-23647 is a medium-severity vulnerability in goauthentik authentik, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23647 and fix it if it is affected.\n\nWhat it is: CVE-2024-23647 is a medium-severity vulnerability in goauthentik authentik, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-23647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- goauthentik.io (Go): affected all versions; no fix listed\n- goauthentik.io (Go): affected all versions; fixed in 2023.8.7\n- goauthentik.io (Go): affected all versions; fixed in 2023.8.7\n- goauthentik.io (Go): affected from 2023.10.0; fixed in 2023.10.7\n- goauthentik.io (Go): affected from 2023.10.0; fixed in 2023.10.7\n- authentik (Bitnami): affected all versions; fixed in 2023.8.7, 2023.10.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23647/ (Markdown: https://insights.sbomify.com/CVE-2024-23647/index.md)","id":"CVE-2024-23647","markdown":"https://insights.sbomify.com/CVE-2024-23647/index.md","name":"CVE-2024-23647","record":{"aliases":["BIT-authentik-2024-23647","GHSA-mrx3-gxjx-hjqj","GO-2024-2479"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity Provider","requires_auth":"none","summary":"Attackers can bypass PKCE protection in Authentik by omitting the code_challenge parameter, enabling CSRF and code injection attacks.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"authentik","vendor":"goauthentik"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks.  Versions 2023.8.7 and 2023.10.7 fix the issue.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PKCE downgrade attack in Authentik","id":"CVE-2024-23647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"security_feature_bypass","year":"2024"},"n_packages":6,"n_references":2,"next":{"headline":"Pimcore Admin Classic Bundle host header injection in the password reset","id":"CVE-2024-23648"},"packages":[{"ecosystem":"Bitnami","fixed":["2023.8.7","2023.10.7"],"introduced":["0","2023.10.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2024-23647"},{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"goauthentik.io","purl":"pkg:golang/goauthentik.io","source":"GO-2024-2479"},{"ecosystem":"Go","fixed":["2023.8.7"],"introduced":["0"],"last_affected":[],"package":"goauthentik.io","purl":null,"source":"GHSA-mrx3-gxjx-hjqj"},{"ecosystem":"Go","fixed":["2023.8.7"],"introduced":["0"],"last_affected":[],"package":"goauthentik.io","purl":"pkg:golang/goauthentik.io","source":"GHSA-mrx3-gxjx-hjqj"},{"ecosystem":"Go","fixed":["2023.10.7"],"introduced":["2023.10.0"],"last_affected":[],"package":"goauthentik.io","purl":null,"source":"GHSA-mrx3-gxjx-hjqj"},{"ecosystem":"Go","fixed":["2023.10.7"],"introduced":["2023.10.0"],"last_affected":[],"package":"goauthentik.io","purl":"pkg:golang/goauthentik.io","source":"GHSA-mrx3-gxjx-hjqj"}],"prev":{"headline":"Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip","id":"CVE-2024-23646"},"products":["authentik"],"published":"2024-01-30","related":[{"cvss_score":9.8,"headline":"authentik: SourceStage bypass via empty POST","id":"CVE-2026-49448","kev_date_added":null,"published":"2026-06-02"},{"cvss_score":9.7,"headline":"authentik potential installation takeover when default admin user is deleted","id":"CVE-2023-46249","kev_date_added":null,"published":"2023-10-31"},{"cvss_score":9.4,"headline":"authentik vulnerable to Improper Authentication via invitation URL token reuse","id":"CVE-2022-23555","kev_date_added":null,"published":"2022-12-28"},{"cvss_score":9.3,"headline":"authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover","id":"CVE-2026-42849","kev_date_added":null,"published":"2026-06-02"},{"cvss_score":9.1,"headline":"authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint","id":"CVE-2026-25227","kev_date_added":null,"published":"2026-02-12"},{"cvss_score":9.1,"headline":"authentik vulnerable to password authentication bypass via X-Forwarded-For HTTP header","id":"CVE-2024-47070","kev_date_added":null,"published":"2024-09-27"},{"cvss_score":9.1,"headline":"Insufficient user check in FlowTokens by Email stage","id":"CVE-2023-26481","kev_date_added":null,"published":"2023-03-04"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-17","vendors":["goauthentik"]},"summary":"Attackers can bypass PKCE protection in Authentik by omitting the code_challenge parameter, enabling CSRF and code injection attacks.","url":"https://insights.sbomify.com/CVE-2024-23647/"}