# CVE-2024-23647: PKCE downgrade attack in Authentik

> Attackers can bypass PKCE protection in Authentik by omitting the code_challenge parameter, enabling CSRF and code injection attacks.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** BIT-authentik-2024-23647, GHSA-mrx3-gxjx-hjqj, GO-2024-2479

## What is CVE-2024-23647?

CVE-2024-23647 is a medium-severity vulnerability in goauthentik authentik, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Authentik is an open-source Identity Provider. There is a bug in our implementation of PKCE that allows an attacker to circumvent the protection that PKCE offers. PKCE adds the code_challenge parameter to the authorization request and adds the code_verifier parameter to the token request. Prior to 2023.8.7 and 2023.10.7, a downgrade scenario is possible: if the attacker removes the code_challenge parameter from the authorization request, authentik will not do the PKCE check. Because of this bug, an attacker can circumvent the protection PKCE offers, such as CSRF attacks and code injection attacks.  Versions 2023.8.7 and 2023.10.7 fix the issue.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2024-23647?

6 open source packages ship an affected version, including goauthentik.io and authentik. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `goauthentik.io` | Go | All versions | None |
| `goauthentik.io` | Go | All versions | 2023.8.7 |
| `goauthentik.io` | Go | All versions | 2023.8.7 |
| `goauthentik.io` | Go | From 2023.10.0 | 2023.10.7 |
| `goauthentik.io` | Go | From 2023.10.0 | 2023.10.7 |
| `authentik` | Bitnami | All versions | 2023.8.7, 2023.10.7 |

Products: Goauthentik Authentik.

## How do I fix CVE-2024-23647?

Upgrade goauthentik.io to a fixed version for your release line: 2023.8.7 or 2023.10.7.

## Is CVE-2024-23647 being exploited?

There is no known exploitation of CVE-2024-23647 in the wild and no public exploit code.

## Other vulnerabilities in goauthentik authentik

- [CVE-2026-49448](https://insights.sbomify.com/CVE-2026-49448/): authentik: SourceStage bypass via empty POST (critical 9.8)
- [CVE-2023-46249](https://insights.sbomify.com/CVE-2023-46249/): authentik potential installation takeover when default admin user is deleted (critical 9.7)
- [CVE-2022-23555](https://insights.sbomify.com/CVE-2022-23555/): authentik vulnerable to Improper Authentication via invitation URL token reuse (critical 9.4)
- [CVE-2026-42849](https://insights.sbomify.com/CVE-2026-42849/): authentik: Reflected XSS in SFE AutosubmitStage allows IDP account takeover (critical 9.3)
- [CVE-2026-25227](https://insights.sbomify.com/CVE-2026-25227/): authentik affected by Remote Code Execution via Context Key Injection in PropertyMapping Test Endpoint (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23647 and fix it if it is affected.

What it is: CVE-2024-23647 is a medium-severity vulnerability in goauthentik authentik, published on 30 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23647 in the wild and no public exploit code.

Affected packages and fixed versions:
- goauthentik.io (Go): affected all versions; no fix listed
- goauthentik.io (Go): affected all versions; fixed in 2023.8.7
- goauthentik.io (Go): affected all versions; fixed in 2023.8.7
- goauthentik.io (Go): affected from 2023.10.0; fixed in 2023.10.7
- goauthentik.io (Go): affected from 2023.10.0; fixed in 2023.10.7
- authentik (Bitnami): affected all versions; fixed in 2023.8.7, 2023.10.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23647/ (Markdown: https://insights.sbomify.com/CVE-2024-23647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23647
- OSV: https://osv.dev/vulnerability/CVE-2024-23647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23647/
Summaries are generated and may contain mistakes; the official description above is the record.
