# CVE-2024-23648: Pimcore Admin Classic Bundle host header injection in the password reset

> Attackers can hijack password reset tokens via Host header injection, leading to account takeover if victims click the malicious link.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** GHSA-mrqg-mwh7-q94j

## What is CVE-2024-23648?

CVE-2024-23648 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pimcore's Admin Classic Bundle provides a backend user interface for Pimcore. The password reset functionality sends to the the user requesting a password change an email containing an URL to reset its password. The URL sent contains a unique token, valid during 24 hours, allowing the user to reset its password. This token is highly sensitive ; as an attacker able to retrieve it would be able to resets the user's password. Prior to version 1.2.3, the reset-password URL is crafted using the "Host" HTTP header of the request sent to request a password reset. This way, an external attacker could send password requests for users, but specify a "Host" header of a website that they control. If the user receiving the mail clicks on the link, the attacker would retrieve the reset token of the victim and perform account takeover. Version 1.2.3 fixes this issue.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-23648?

2 open source packages ship an affected version, including pimcore/admin-ui-classic-bundle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.3 |
| `pimcore/admin-ui-classic-bundle` | Packagist | All versions | 1.2.3 |

Products: Pimcore Admin Classic Bundle.

## How do I fix CVE-2024-23648?

Upgrade pimcore/admin-ui-classic-bundle to 1.2.3 or later.

## Is CVE-2024-23648 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23648 exists.

## Other vulnerabilities in pimcore admin-ui-classic-bundle

- [CVE-2024-23646](https://insights.sbomify.com/CVE-2024-23646/): Pimcore Admin Classic Bundle SQL Injection in Admin download files as zip (high 8.8)
- [CVE-2023-49075](https://insights.sbomify.com/CVE-2023-49075/): Pimcore Admin UI has Two Factor Authentication disabled for non admin security firewalls (high 8.5)
- [CVE-2024-25625](https://insights.sbomify.com/CVE-2024-25625/): Pimcore Host Header Injection in user invitation link (high 8.1)
- [CVE-2025-24980](https://insights.sbomify.com/CVE-2025-24980/): Pimcore Admin Classic Bundle allows user enumeration (medium 6.9)
- [CVE-2024-24822](https://insights.sbomify.com/CVE-2024-24822/): Pimcore Admin Classic Bundle permissions are not getting checked when working with tags (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23648 and fix it if it is affected.

What it is: CVE-2024-23648 is a high-severity vulnerability in pimcore admin-ui-classic-bundle, published on 24 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23648 exists.

Affected packages and fixed versions:
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.3
- pimcore/admin-ui-classic-bundle (Packagist): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23648/ (Markdown: https://insights.sbomify.com/CVE-2024-23648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23648
- OSV: https://osv.dev/vulnerability/CVE-2024-23648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23648/
Summaries are generated and may contain mistakes; the official description above is the record.
