CVE-2024-23653 BuildKit interactive containers API does not validate entitlements check

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2024-23653?

CVE-2024-23653 is a critical vulnerability in moby buildkit, published on 31 Jan 2024.

Official description

BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.

Weakness: CWE-863

Which versions are affected by CVE-2024-23653?

3 open source packages ship an affected version, including github.com/moby/buildkit. It affects 1 product.

PackageAffectedFixed in
github.com/moby/buildkit GoAll versions0.12.5
github.com/moby/buildkit GoAll versions0.12.5
github.com/moby/buildkit GoAll versions0.12.5
Linux distribution packages (2)
buildkit openSUSE:TumbleweedAll versions0.12.5-2.1
docker-stable openSUSE:TumbleweedAll versions24.0.9_ce-4.1

Products include Mobyproject Buildkit.

How do I fix CVE-2024-23653?

Upgrade github.com/moby/buildkit to 0.12.5 or later.

Is CVE-2024-23653 being exploited?

There is no known exploitation of CVE-2024-23653 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as AZL-34078, AZL-34079, AZL-34081, AZL-34084, AZL-34998, AZL-35433 and 9 more.

Is CVE-2024-23653 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free