{"answers":{"affected":"2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.servlets.resolver. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23673 exists.","fix":"Upgrade org.apache.sling:org.apache.sling.servlets.resolver to 2.11.0 or later.","what":"CVE-2024-23673 is a high-severity path traversal vulnerability in Apache Sling Servlets Resolver, published on 6 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23673 and fix it if it is affected.\n\nWhat it is: CVE-2024-23673 is a high-severity path traversal vulnerability in Apache Sling Servlets Resolver, published on 6 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23673 exists.\n\nAffected packages and fixed versions:\n- org.apache.sling:org.apache.sling.servlets.resolver (Maven): affected all versions; fixed in 2.11.0\n- org.apache.sling:org.apache.sling.servlets.resolver (Maven): affected all versions; fixed in 2.11.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23673/ (Markdown: https://insights.sbomify.com/CVE-2024-23673/index.md)","id":"CVE-2024-23673","markdown":"https://insights.sbomify.com/CVE-2024-23673/index.md","name":"CVE-2024-23673","record":{"aliases":["GHSA-h2rq-qhr7-53gm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java web framework","requires_auth":"low_privilege","summary":"Attackers with repository write access can execute malicious code via path traversal in Apache Sling Servlets Resolver.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"sling_servlets_resolver","vendor":"apache"}],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system.\nIf the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. \n\nUsers are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2025-08-17","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-08-17T12:22:57Z","kind":"github_poc","ref":"https://github.com/shoucheng3/apache__sling-org-apache-sling-servlets-resolver_CVE-2024-23673_2-10-0","stars":0,"title":null}],"tier":"weaponised"},"has_fix":true,"headline":"Apache Sling Servlets Resolver: Malicious code execution via path traversal","id":"CVE-2024-23673","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2024"},"n_packages":2,"n_references":2,"next":{"headline":"Auth bypass in n/a","id":"CVE-2024-23674"},"packages":[{"ecosystem":"Maven","fixed":["2.11.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.servlets.resolver","purl":null,"source":"GHSA-h2rq-qhr7-53gm"},{"ecosystem":"Maven","fixed":["2.11.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.sling:org.apache.sling.servlets.resolver","purl":"pkg:maven/org.apache.sling/org.apache.sling.servlets.resolver","source":"GHSA-h2rq-qhr7-53gm"}],"prev":{"headline":"Apache Tomcat: WebSocket DoS with incomplete closing handshake","id":"CVE-2024-23672"},"products":["Apache Sling Servlets Resolver"],"published":"2024-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-09","vendors":["Apache Software Foundation"]},"summary":"Attackers with repository write access can execute malicious code via path traversal in Apache Sling Servlets Resolver.","url":"https://insights.sbomify.com/CVE-2024-23673/"}