# CVE-2024-23673: Apache Sling Servlets Resolver: Malicious code execution via path traversal

> Attackers with repository write access can execute malicious code via path traversal in Apache Sling Servlets Resolver.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2024
- **Updated:** 9 May 2025
- **Also known as:** GHSA-h2rq-qhr7-53gm

## What is CVE-2024-23673?

CVE-2024-23673 is a high-severity path traversal vulnerability in Apache Sling Servlets Resolver, published on 6 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Malicious code execution via path traversal in Apache Software Foundation Apache Sling Servlets Resolver.This issue affects all version of Apache Sling Servlets Resolver before 2.11.0. However, whether a system is vulnerable to this attack depends on the exact configuration of the system.
If the system is vulnerable, a user with write access to the repository might be able to trick the Sling Servlet Resolver to load a previously uploaded script. 

Users are recommended to upgrade to version 2.11.0, which fixes this issue. It is recommended to upgrade, regardless of whether your system configuration currently allows this attack or not.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-23673?

2 open source packages ship an affected version, including org.apache.sling:org.apache.sling.servlets.resolver. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.sling:org.apache.sling.servlets.resolver` | Maven | All versions | 2.11.0 |
| `org.apache.sling:org.apache.sling.servlets.resolver` | Maven | All versions | 2.11.0 |

Products: Apache Sling Servlets Resolver.

## How do I fix CVE-2024-23673?

Upgrade org.apache.sling:org.apache.sling.servlets.resolver to 2.11.0 or later.

## Is CVE-2024-23673 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23673 exists.

Public exploit code:

- https://github.com/shoucheng3/apache__sling-org-apache-sling-servlets-resolver_CVE-2024-23673_2-10-0 (github_poc): https://github.com/shoucheng3/apache__sling-org-apache-sling-servlets-resolver_CVE-2024-23673_2-10-0

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23673 and fix it if it is affected.

What it is: CVE-2024-23673 is a high-severity path traversal vulnerability in Apache Sling Servlets Resolver, published on 6 Feb 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23673 exists.

Affected packages and fixed versions:
- org.apache.sling:org.apache.sling.servlets.resolver (Maven): affected all versions; fixed in 2.11.0
- org.apache.sling:org.apache.sling.servlets.resolver (Maven): affected all versions; fixed in 2.11.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23673/ (Markdown: https://insights.sbomify.com/CVE-2024-23673/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23673
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23673
- OSV: https://osv.dev/vulnerability/CVE-2024-23673

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23673/
Summaries are generated and may contain mistakes; the official description above is the record.
