# CVE-2024-23680: AWS Encryption SDK for Java Improper Verification of Cryptographic Signature

> Attackers can bypass cryptographic signature verification in the AWS Encryption SDK for Java, potentially compromising data integrity.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-55xh-53m6-936r

## What is CVE-2024-23680?

CVE-2024-23680 is a medium-severity vulnerability in amazon:aws_encryption_sdk, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

AWS Encryption SDK for Java versions 2.0.0 to 2.2.0 and less than 1.9.0 incorrectly validates some invalid ECDSA signatures.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2024-23680?

4 open source packages ship an affected version, including com.amazonaws:aws-encryption-sdk-java. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.amazonaws:aws-encryption-sdk-java` | Maven | All versions | 1.9.0 |
| `com.amazonaws:aws-encryption-sdk-java` | Maven | All versions | 1.9.0 |
| `com.amazonaws:aws-encryption-sdk-java` | Maven | From 2.0.0 | 2.2.0 |
| `com.amazonaws:aws-encryption-sdk-java` | Maven | From 2.0.0 | 2.2.0 |

Products: Amazon Aws Encryption Sdk.

## How do I fix CVE-2024-23680?

Upgrade com.amazonaws:aws-encryption-sdk-java to a fixed version for your release line: 1.9.0 or 2.2.0.

## Is CVE-2024-23680 being exploited?

There is no known exploitation of CVE-2024-23680 in the wild and no public exploit code.

## Other vulnerabilities in amazon:aws_encryption_sdk

- [CVE-2020-8897](https://insights.sbomify.com/CVE-2020-8897/): Robustness weakness in AWS KMS and Encryption SDKs (medium 4.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23680 and fix it if it is affected.

What it is: CVE-2024-23680 is a medium-severity vulnerability in amazon:aws_encryption_sdk, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23680 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.amazonaws:aws-encryption-sdk-java (Maven): affected all versions; fixed in 1.9.0
- com.amazonaws:aws-encryption-sdk-java (Maven): affected all versions; fixed in 1.9.0
- com.amazonaws:aws-encryption-sdk-java (Maven): affected from 2.0.0; fixed in 2.2.0
- com.amazonaws:aws-encryption-sdk-java (Maven): affected from 2.0.0; fixed in 2.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23680/ (Markdown: https://insights.sbomify.com/CVE-2024-23680/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23680
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23680
- OSV: https://osv.dev/vulnerability/CVE-2024-23680

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23680/
Summaries are generated and may contain mistakes; the official description above is the record.
