# CVE-2024-23684: upokecenter CBOR Denial of Service

> An attacker can cause a denial of service in applications using the upokecenter CBOR Java library by submitting maliciously crafted input.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-fj2w-wfgv-mwq6

## What is CVE-2024-23684?

CVE-2024-23684 is a high-severity denial of service vulnerability in peteroupc:cbor, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inefficient algorithmic complexity in DecodeFromBytes function in com.upokecenter.cbor Java implementation of Concise Binary Object Representation (CBOR) versions 4.0.0 to 4.5.1 allows an attacker to cause a denial of service by passing a maliciously crafted input. Depending on an application's use of this library, this may be a remote attacker.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2024-23684?

2 open source packages ship an affected version, including com.upokecenter:cbor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.upokecenter:cbor` | Maven | From 4.0.0 | 4.5.1 |
| `com.upokecenter:cbor` | Maven | From 4.0.0 | 4.5.1 |

Products: Peteroupc Cbor.

## How do I fix CVE-2024-23684?

Upgrade com.upokecenter:cbor to 4.5.1 or later.

## Is CVE-2024-23684 being exploited?

There is no known exploitation of CVE-2024-23684 in the wild and no public exploit code.

## Other vulnerabilities in peteroupc:cbor

- [CVE-2024-21909](https://insights.sbomify.com/CVE-2024-21909/): Denial of service in CBOR library (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23684 and fix it if it is affected.

What it is: CVE-2024-23684 is a high-severity denial of service vulnerability in peteroupc:cbor, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23684 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.upokecenter:cbor (Maven): affected from 4.0.0; fixed in 4.5.1
- com.upokecenter:cbor (Maven): affected from 4.0.0; fixed in 4.5.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23684/ (Markdown: https://insights.sbomify.com/CVE-2024-23684/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23684
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23684
- OSV: https://osv.dev/vulnerability/CVE-2024-23684

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23684/
Summaries are generated and may contain mistakes; the official description above is the record.
