# CVE-2024-23686: DependencyCheck Debug Mode Logging of NVD API Key

> Attackers can recover NVD API keys from log files when DependencyCheck is run in debug mode, exposing sensitive credentials.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-frxm-v7q3-v2wv, GHSA-qqhq-8r2c-c3f5

## What is CVE-2024-23686?

CVE-2024-23686 is a medium-severity vulnerability in owasp:dependency-check, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

DependencyCheck for Maven 9.0.0 to 9.0.6, for CLI version 9.0.0 to 9.0.5, and for Ant versions 9.0.0 to 9.0.5, when used in debug mode, allows an attacker to recover the NVD API Key from a log file.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2024-23686?

12 open source packages ship an affected version, including org.owasp:dependency-check-ant, org.owasp:dependency-check-cli and org.owasp:dependency-check-maven. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.owasp:dependency-check-ant` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-ant` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-ant` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-ant` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-cli` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-cli` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-cli` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-cli` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-maven` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-maven` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-maven` | Maven | From 9.0.0 | 9.0.6 |
| `org.owasp:dependency-check-maven` | Maven | From 9.0.0 | 9.0.6 |

Products: Owasp Dependency-Check.

## How do I fix CVE-2024-23686?

Upgrade org.owasp:dependency-check-ant to 9.0.6 or later.

## Is CVE-2024-23686 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23686 exists.

## Other vulnerabilities in owasp:dependency-check

- [CVE-2018-12036](https://insights.sbomify.com/CVE-2018-12036/): Path Traversal in OWASP Dependency-Check (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23686 and fix it if it is affected.

What it is: CVE-2024-23686 is a medium-severity vulnerability in owasp:dependency-check, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23686 exists.

Affected packages and fixed versions:
- org.owasp:dependency-check-ant (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-ant (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-ant (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-ant (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-cli (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-cli (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-cli (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-cli (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-maven (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-maven (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-maven (Maven): affected from 9.0.0; fixed in 9.0.6
- org.owasp:dependency-check-maven (Maven): affected from 9.0.0; fixed in 9.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23686/ (Markdown: https://insights.sbomify.com/CVE-2024-23686/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23686
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23686
- OSV: https://osv.dev/vulnerability/CVE-2024-23686

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23686/
Summaries are generated and may contain mistakes; the official description above is the record.
