# CVE-2024-23688: Consensys Discovery Nonce Reuse

> Reusing AES/GCM nonces in Consensys Discovery exposes session keys, allowing attackers to decrypt peer communications.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jan 2024
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-w3hj-wr2q-x83g

## What is CVE-2024-23688?

CVE-2024-23688 is a medium-severity vulnerability in consensys:discovery, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Consensys Discovery versions less than 0.4.5 uses the same AES/GCM nonce for the entire session. which should ideally be unique for every message. The node's private key isn't compromised, only the session key generated for specific peer communication is exposed.

Weakness: CWE-330 (Use of Insufficiently Random Values), CWE-323 (Reusing a Nonce, Key Pair in Encryption)

## Which versions are affected by CVE-2024-23688?

2 open source packages ship an affected version, including tech.pegasys.discovery:discovery. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tech.pegasys.discovery:discovery` | Maven | All versions | 0.4.5 |
| `tech.pegasys.discovery:discovery` | Maven | All versions | 0.4.5 |

Products: Consensys Discovery.

## How do I fix CVE-2024-23688?

Upgrade tech.pegasys.discovery:discovery to 0.4.5 or later.

## Is CVE-2024-23688 being exploited?

There is no known exploitation of CVE-2024-23688 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23688 and fix it if it is affected.

What it is: CVE-2024-23688 is a medium-severity vulnerability in consensys:discovery, published on 19 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23688 in the wild and no public exploit code.

Affected packages and fixed versions:
- tech.pegasys.discovery:discovery (Maven): affected all versions; fixed in 0.4.5
- tech.pegasys.discovery:discovery (Maven): affected all versions; fixed in 0.4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23688/ (Markdown: https://insights.sbomify.com/CVE-2024-23688/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23688
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23688
- OSV: https://osv.dev/vulnerability/CVE-2024-23688

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23688/
Summaries are generated and may contain mistakes; the official description above is the record.
