# CVE-2024-23722: Null dereference in n/a

> An attacker can crash the Fluent Bit log processor by sending a malformed HTTP payload, causing a denial of service and preventing log delivery.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Mar 2024
- **Updated:** 6 Aug 2024
- **Also known as:** AZL-37083, BIT-fluent-bit-2024-23722, GHSA-7x4x-j7vx-3p29

## What is CVE-2024-23722?

CVE-2024-23722 is a high-severity vulnerability in n/a, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Fluent Bit 2.1.8 through 2.2.1, a NULL pointer dereference can be caused via an invalid HTTP payload with the content type of x-www-form-urlencoded. It crashes and does not restart. This could result in logs not being delivered properly.

Weakness: CWE-476 (NULL Pointer Dereference)

## Which versions are affected by CVE-2024-23722?

1 open source package ship an affected version, including fluent-bit. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fluent-bit` | Bitnami | From 2.1.8 | 2.2.2 |

Products: Treasuredata Fluent Bit.

## How do I fix CVE-2024-23722?

Upgrade fluent-bit to 2.2.2 or later.

## Is CVE-2024-23722 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23722 exists.

Public exploit code:

- https://github.com/alexcote1/CVE-2024-23722-poc (github_poc): https://github.com/alexcote1/CVE-2024-23722-poc

## Other vulnerabilities in n/a

- [CVE-2024-4323](https://insights.sbomify.com/CVE-2024-4323/): Fluent Bit Memory Corruption Vulnerability (critical 9.8)
- [CVE-2021-36088](https://insights.sbomify.com/CVE-2021-36088/): Use after free in n/a (critical 9.8)
- [CVE-2025-12977](https://insights.sbomify.com/CVE-2025-12977/): CVE-2025-12977 (critical 9.1)
- [CVE-2025-12970](https://insights.sbomify.com/CVE-2025-12970/): CVE-2025-12970 (high 8.8)
- [CVE-2021-46878](https://insights.sbomify.com/CVE-2021-46878/): Use after free in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23722 and fix it if it is affected.

What it is: CVE-2024-23722 is a high-severity vulnerability in n/a, published on 26 Mar 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23722 exists.

Affected packages and fixed versions:
- fluent-bit (Bitnami): affected from 2.1.8; fixed in 2.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23722/ (Markdown: https://insights.sbomify.com/CVE-2024-23722/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23722
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23722
- OSV: https://osv.dev/vulnerability/CVE-2024-23722

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23722/
Summaries are generated and may contain mistakes; the official description above is the record.
