# CVE-2024-23724: Ghost has possible Cross-site Scripting issue

> Stored XSS in Ghost CMS allows contributors to escalate privileges and take over accounts via malicious SVG profile pictures.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 11 Feb 2024
- **Updated:** 7 Nov 2024
- **Also known as:** BIT-ghost-2024-23724, GHSA-99vc-xw8j-phjm

## What is CVE-2024-23724?

CVE-2024-23724 is a critical cross-site scripting vulnerability in n/a, published on 11 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Ghost through 5.76.0 allows stored XSS, and resultant privilege escalation in which a contributor can take over any account, via an SVG profile picture that contains JavaScript code to interact with the API on localhost TCP port 3001. NOTE: The discoverer reports that "The vendor does not view this as a valid vector."

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23724?

3 open source packages ship an affected version, including ghost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ghost` | Bitnami | All versions | 5.82.11 |
| `ghost` | npm | All versions to 5.76.0 | None |
| `ghost` | npm | All versions to 5.76.0 | None |

Products: Ghost Ghost.

## How do I fix CVE-2024-23724?

Upgrade ghost to 5.82.11 or later.

## Is CVE-2024-23724 being exploited?

There is no known exploitation of CVE-2024-23724 in the wild and no public exploit code.

Public exploit code:

- https://github.com/Youssefdds/CVE-2024-23724 (github_poc): https://github.com/Youssefdds/CVE-2024-23724
- Ghost-CMS Exploit is python script. This script first performs brute-force authentication attempts using the provided wordlists. If valid credentials are found, it proceeds to check for CVE-2024-23724 vulnerability and generates an exploit payload if vulnerable. (github_poc): https://github.com/gl1tch0x1/Ghost-CMS-Exploit

## Other vulnerabilities in n/a

- [CVE-2022-27139](https://insights.sbomify.com/CVE-2022-27139/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-28397](https://insights.sbomify.com/CVE-2022-28397/): Arbitrary file upload in Ghost (critical 9.8)
- [CVE-2022-41654](https://insights.sbomify.com/CVE-2022-41654/): ghost vulnerable to unauthorized newsletter modification via improper access controls (critical 9.6)
- [CVE-2026-26980](https://insights.sbomify.com/CVE-2026-26980/): Ghost has a SQL Injection in its Content API (critical 9.4)
- [CVE-2024-34451](https://insights.sbomify.com/CVE-2024-34451/): Security feature bypass in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23724 and fix it if it is affected.

What it is: CVE-2024-23724 is a critical cross-site scripting vulnerability in n/a, published on 11 Feb 2024. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23724 in the wild and no public exploit code.

Affected packages and fixed versions:
- ghost (Bitnami): affected all versions; fixed in 5.82.11
- ghost (npm): affected all versions up to 5.76.0; no fix listed
- ghost (npm): affected all versions up to 5.76.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23724/ (Markdown: https://insights.sbomify.com/CVE-2024-23724/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23724
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23724
- OSV: https://osv.dev/vulnerability/CVE-2024-23724

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23724/
Summaries are generated and may contain mistakes; the official description above is the record.
