{"answers":{"affected":"3 open source packages ship an affected version, including ghost. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23725 in the wild and no public exploit code.","fix":"Upgrade ghost to 5.76.0 or later.","what":"CVE-2024-23725 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23725 and fix it if it is affected.\n\nWhat it is: CVE-2024-23725 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-23725 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ghost (Bitnami): affected all versions; fixed in 5.76.0\n- ghost (npm): affected all versions; fixed in 5.76.0\n- ghost (npm): affected all versions; fixed in 5.76.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23725/ (Markdown: https://insights.sbomify.com/CVE-2024-23725/index.md)","id":"CVE-2024-23725","markdown":"https://insights.sbomify.com/CVE-2024-23725/index.md","name":"CVE-2024-23725","record":{"aliases":["BIT-ghost-2024-23725","GHSA-fh38-9fgr-454w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ghost CMS","requires_auth":"none","summary":"Attackers can inject malicious scripts via post excerpts in Ghost CMS, potentially executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ghost","vendor":"ghost"}],"cvss":{"score":6.1,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Ghost before 5.76.0 allows XSS via a post excerpt in excerpt.js. An XSS payload can be rendered in post summaries.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in Ghost","id":"CVE-2024-23725","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2024-23726"},"packages":[{"ecosystem":"Bitnami","fixed":["5.76.0"],"introduced":["0"],"last_affected":[],"package":"ghost","purl":"pkg:bitnami/ghost","source":"BIT-ghost-2024-23725"},{"ecosystem":"npm","fixed":["5.76.0"],"introduced":["0"],"last_affected":[],"package":"ghost","purl":null,"source":"GHSA-fh38-9fgr-454w"},{"ecosystem":"npm","fixed":["5.76.0"],"introduced":["0"],"last_affected":[],"package":"ghost","purl":"pkg:npm/ghost","source":"GHSA-fh38-9fgr-454w"}],"prev":{"headline":"Ghost has possible Cross-site Scripting issue","id":"CVE-2024-23724"},"products":["n/a"],"published":"2024-01-21","related":[{"cvss_score":9.8,"headline":"Arbitrary file upload in Ghost","id":"CVE-2022-27139","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.8,"headline":"Arbitrary file upload in Ghost","id":"CVE-2022-28397","kev_date_added":null,"published":"2022-04-12"},{"cvss_score":9.6,"headline":"ghost vulnerable to unauthorized newsletter modification via improper access controls","id":"CVE-2022-41654","kev_date_added":null,"published":"2022-12-23"},{"cvss_score":9.4,"headline":"Ghost has a SQL Injection in its Content API","id":"CVE-2026-26980","kev_date_added":null,"published":"2026-02-20"},{"cvss_score":9.1,"headline":"Security feature bypass in n/a","id":"CVE-2024-34451","kev_date_added":null,"published":"2024-06-16"},{"cvss_score":9,"headline":"Ghost has possible Cross-site Scripting issue","id":"CVE-2024-23724","kev_date_added":null,"published":"2024-02-11"},{"cvss_score":9,"headline":"Cross-site scripting in Ghost","id":"CVE-2022-47194","kev_date_added":null,"published":"2023-01-19"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["n/a"]},"summary":"Attackers can inject malicious scripts via post excerpts in Ghost CMS, potentially executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2024-23725/"}