{"answers":{"affected":"3 open source packages ship an affected version, including llama-hub. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23730 in the wild and no public exploit code.","fix":"Upgrade llama-hub to 0.0.67 or later.","what":"CVE-2024-23730 is a critical vulnerability in n/a, published on 21 Jan 2024."},"fix_prompt":"Check this codebase for CVE-2024-23730 and fix it if it is affected.\n\nWhat it is: CVE-2024-23730 is a critical vulnerability in n/a, published on 21 Jan 2024. \nExploitation: There is no known exploitation of CVE-2024-23730 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- llama-hub (PyPI): affected all versions; fixed in 0.0.67\n- llama-hub (PyPI): affected all versions; fixed in 0.0.67\n- llama-hub (PyPI): affected all versions; fixed in 0.0.67\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23730/ (Markdown: https://insights.sbomify.com/CVE-2024-23730/index.md)","id":"CVE-2024-23730","markdown":"https://insights.sbomify.com/CVE-2024-23730/index.md","name":"CVE-2024-23730","record":{"aliases":["GHSA-297x-2qf3-jrj3","PYSEC-2026-393"],"analysis":null,"analysis_generated_by":null,"assigner":"mitre","cpe":[{"product":"llamahub","vendor":"llamahub"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[],"description":"The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unsafe yaml deserialization in llama-hub","id":"CVE-2024-23730","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2024"},"n_packages":3,"n_references":3,"next":{"headline":"Code execution in Embedchain","id":"CVE-2024-23731"},"packages":[{"ecosystem":"PyPI","fixed":["0.0.67"],"introduced":["0"],"last_affected":[],"package":"llama-hub","purl":null,"source":"GHSA-297x-2qf3-jrj3"},{"ecosystem":"PyPI","fixed":["0.0.67"],"introduced":["0"],"last_affected":[],"package":"llama-hub","purl":"pkg:pypi/llama-hub","source":"GHSA-297x-2qf3-jrj3"},{"ecosystem":"PyPI","fixed":["0.0.67"],"introduced":["0"],"last_affected":[],"package":"llama-hub","purl":"pkg:pypi/llama-hub","source":"PYSEC-2026-393"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2024-23729"},"products":["n/a"],"published":"2024-01-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-05-30","vendors":["n/a"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2024-23730/"}