# CVE-2024-23730: Unsafe yaml deserialization in llama-hub


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Jan 2024
- **Updated:** 30 May 2025
- **Also known as:** GHSA-297x-2qf3-jrj3, PYSEC-2026-393

## What is CVE-2024-23730?

CVE-2024-23730 is a critical vulnerability in n/a, published on 21 Jan 2024. 

### Official description

The OpenAPI and ChatGPT plugin loaders in LlamaHub (aka llama-hub) before 0.0.67 allow attackers to execute arbitrary code because safe_load is not used for YAML.

## Which versions are affected by CVE-2024-23730?

3 open source packages ship an affected version, including llama-hub. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-hub` | PyPI | All versions | 0.0.67 |
| `llama-hub` | PyPI | All versions | 0.0.67 |
| `llama-hub` | PyPI | All versions | 0.0.67 |

Products: Llamahub Llamahub.

## How do I fix CVE-2024-23730?

Upgrade llama-hub to 0.0.67 or later.

## Is CVE-2024-23730 being exploited?

There is no known exploitation of CVE-2024-23730 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23730 and fix it if it is affected.

What it is: CVE-2024-23730 is a critical vulnerability in n/a, published on 21 Jan 2024. 
Exploitation: There is no known exploitation of CVE-2024-23730 in the wild and no public exploit code.

Affected packages and fixed versions:
- llama-hub (PyPI): affected all versions; fixed in 0.0.67
- llama-hub (PyPI): affected all versions; fixed in 0.0.67
- llama-hub (PyPI): affected all versions; fixed in 0.0.67

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23730/ (Markdown: https://insights.sbomify.com/CVE-2024-23730/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23730
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23730
- OSV: https://osv.dev/vulnerability/CVE-2024-23730

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23730/
Summaries are generated and may contain mistakes; the official description above is the record.
