{"answers":{"affected":"3 open source packages ship an affected version, including embedchain. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23731 in the wild and no public exploit code.","fix":"Upgrade embedchain to 0.1.57 or later.","what":"CVE-2024-23731 is a critical code injection vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23731 and fix it if it is affected.\n\nWhat it is: CVE-2024-23731 is a critical code injection vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2024-23731 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- embedchain (PyPI): affected all versions; fixed in 0.1.57\n- embedchain (PyPI): affected all versions; fixed in 0.1.57\n- embedchain (PyPI): affected all versions; fixed in 0.1.57\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23731/ (Markdown: https://insights.sbomify.com/CVE-2024-23731/index.md)","id":"CVE-2024-23731","markdown":"https://insights.sbomify.com/CVE-2024-23731/index.md","name":"CVE-2024-23731","record":{"aliases":["GHSA-rhhj-5436-95vf","PYSEC-2024-7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Embedchain Python library","requires_auth":"none","summary":"Attackers can execute arbitrary code via the OpenAPI loader in Embedchain due to unsafe YAML loading.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"embedchain","vendor":"embedchain"}],"cvss":{"score":9.8,"severity":"critical","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-88","name":"Improper Neutralization of Argument Delimiters in a Command"}],"description":"The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code execution in Embedchain","id":"CVE-2024-23731","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"ReDoS in Embedchain","id":"CVE-2024-23732"},"packages":[{"ecosystem":"PyPI","fixed":["0.1.57"],"introduced":["0"],"last_affected":[],"package":"embedchain","purl":null,"source":"GHSA-rhhj-5436-95vf"},{"ecosystem":"PyPI","fixed":["0.1.57"],"introduced":["0"],"last_affected":[],"package":"embedchain","purl":"pkg:pypi/embedchain","source":"GHSA-rhhj-5436-95vf"},{"ecosystem":"PyPI","fixed":["0.1.57"],"introduced":["0"],"last_affected":[],"package":"embedchain","purl":"pkg:pypi/embedchain","source":"PYSEC-2024-7"}],"prev":{"headline":"Unsafe yaml deserialization in llama-hub","id":"CVE-2024-23730"},"products":["n/a"],"published":"2024-01-21","related":[{"cvss_score":7.5,"headline":"ReDoS in Embedchain","id":"CVE-2024-23732","kev_date_added":null,"published":"2024-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via the OpenAPI loader in Embedchain due to unsafe YAML loading.","url":"https://insights.sbomify.com/CVE-2024-23731/"}