# CVE-2024-23731: Code execution in Embedchain

> Attackers can execute arbitrary code via the OpenAPI loader in Embedchain due to unsafe YAML loading.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2024
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-rhhj-5436-95vf, PYSEC-2024-7

## What is CVE-2024-23731?

CVE-2024-23731 is a critical code injection vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The OpenAPI loader in Embedchain before 0.1.57 allows attackers to execute arbitrary code, related to the openapi.py yaml.load function argument.

Weakness: CWE-88 (Improper Neutralization of Argument Delimiters in a Command)

## Which versions are affected by CVE-2024-23731?

3 open source packages ship an affected version, including embedchain. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `embedchain` | PyPI | All versions | 0.1.57 |
| `embedchain` | PyPI | All versions | 0.1.57 |
| `embedchain` | PyPI | All versions | 0.1.57 |

Products: Embedchain Embedchain.

## How do I fix CVE-2024-23731?

Upgrade embedchain to 0.1.57 or later.

## Is CVE-2024-23731 being exploited?

There is no known exploitation of CVE-2024-23731 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-23732](https://insights.sbomify.com/CVE-2024-23732/): ReDoS in Embedchain (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23731 and fix it if it is affected.

What it is: CVE-2024-23731 is a critical code injection vulnerability in n/a, published on 21 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23731 in the wild and no public exploit code.

Affected packages and fixed versions:
- embedchain (PyPI): affected all versions; fixed in 0.1.57
- embedchain (PyPI): affected all versions; fixed in 0.1.57
- embedchain (PyPI): affected all versions; fixed in 0.1.57

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23731/ (Markdown: https://insights.sbomify.com/CVE-2024-23731/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23731
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23731
- OSV: https://osv.dev/vulnerability/CVE-2024-23731

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23731/
Summaries are generated and may contain mistakes; the official description above is the record.
