{"answers":{"affected":"3 open source packages ship an affected version, including metagpt. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23750 exists.","fix":"Upgrade metagpt to 0.6.5 or later.","what":"CVE-2024-23750 is a high-severity command injection vulnerability in n/a, published on 22 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2024-23750 and fix it if it is affected.\n\nWhat it is: CVE-2024-23750 is a high-severity command injection vulnerability in n/a, published on 22 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23750 exists.\n\nAffected packages and fixed versions:\n- metagpt (PyPI): affected all versions up to 0.6.6; no fix listed\n- metagpt (PyPI): affected all versions up to 0.6.6; no fix listed\n- metagpt (PyPI): affected all versions; fixed in 0.6.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23750/ (Markdown: https://insights.sbomify.com/CVE-2024-23750/index.md)","id":"CVE-2024-23750","markdown":"https://insights.sbomify.com/CVE-2024-23750/index.md","name":"CVE-2024-23750","record":{"aliases":["GHSA-g7ph-8423-pf4j","PYSEC-2024-9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python AI agent library","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary code via shell metacharacters in the QaEngineer role of the MetaGPT library.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"metagpt","vendor":"deepwisdom"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because RunCode.run_script() passes shell metacharacters to subprocess.Popen.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Code execution in metagpt","id":"CVE-2024-23750","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"command_injection","year":"2024"},"n_packages":3,"n_references":1,"next":{"headline":"SQL injection in llama-index","id":"CVE-2024-23751"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.6.6"],"package":"metagpt","purl":null,"source":"GHSA-g7ph-8423-pf4j"},{"ecosystem":"PyPI","fixed":[],"introduced":["0"],"last_affected":["0.6.6"],"package":"metagpt","purl":"pkg:pypi/metagpt","source":"GHSA-g7ph-8423-pf4j"},{"ecosystem":"PyPI","fixed":["0.6.5"],"introduced":["0"],"last_affected":[],"package":"metagpt","purl":"pkg:pypi/metagpt","source":"PYSEC-2024-9"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2024-23749"},"products":["n/a"],"published":"2024-01-22","related":[{"cvss_score":9.8,"headline":"Foundation Agents MetaGPT deserialize_message Deserialization of Untrusted Data Remote Code Execution Vulnerability","id":"CVE-2026-0760","kev_date_added":null,"published":"2026-01-23"},{"cvss_score":9.8,"headline":"Foundation Agents MetaGPT actionoutput_str_to_mapping Code Injection Remote Code Execution Vulnerability","id":"CVE-2026-0761","kev_date_added":null,"published":"2026-01-23"},{"cvss_score":6.9,"headline":"FoundationAgents MetaGPT Tree-of-Thought Solver tot.py generate_thoughts code injection","id":"CVE-2026-6110","kev_date_added":null,"published":"2026-04-12"},{"cvss_score":6.9,"headline":"FoundationAgents MetaGPT HumanEvalBenchmark/MBPPBenchmark check_solution code injection","id":"CVE-2026-5970","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":6.9,"headline":"FoundationAgents MetaGPT XML action_node.py ActionNode.xml_fill eval injection","id":"CVE-2026-5971","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":6.9,"headline":"FoundationAgents MetaGPT terminal.py Terminal.run_command os command injection","id":"CVE-2026-5972","kev_date_added":null,"published":"2026-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-06-20","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via shell metacharacters in the QaEngineer role of the MetaGPT library.","url":"https://insights.sbomify.com/CVE-2024-23750/"}