# CVE-2024-23750: Code execution in metagpt

> Attackers can execute arbitrary code via shell metacharacters in the QaEngineer role of the MetaGPT library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2024
- **Updated:** 20 Jun 2025
- **Also known as:** GHSA-g7ph-8423-pf4j, PYSEC-2024-9

## What is CVE-2024-23750?

CVE-2024-23750 is a high-severity command injection vulnerability in n/a, published on 22 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

MetaGPT through 0.6.4 allows the QaEngineer role to execute arbitrary code because RunCode.run_script() passes shell metacharacters to subprocess.Popen.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2024-23750?

3 open source packages ship an affected version, including metagpt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `metagpt` | PyPI | All versions to 0.6.6 | None |
| `metagpt` | PyPI | All versions to 0.6.6 | None |
| `metagpt` | PyPI | All versions | 0.6.5 |

Products: Deepwisdom Metagpt.

## How do I fix CVE-2024-23750?

Upgrade metagpt to 0.6.5 or later.

## Is CVE-2024-23750 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23750 exists.

## Other vulnerabilities in n/a

- [CVE-2026-0760](https://insights.sbomify.com/CVE-2026-0760/): Foundation Agents MetaGPT deserialize_message Deserialization of Untrusted Data Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2026-0761](https://insights.sbomify.com/CVE-2026-0761/): Foundation Agents MetaGPT actionoutput_str_to_mapping Code Injection Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2026-6110](https://insights.sbomify.com/CVE-2026-6110/): FoundationAgents MetaGPT Tree-of-Thought Solver tot.py generate_thoughts code injection (medium 6.9)
- [CVE-2026-5970](https://insights.sbomify.com/CVE-2026-5970/): FoundationAgents MetaGPT HumanEvalBenchmark/MBPPBenchmark check_solution code injection (medium 6.9)
- [CVE-2026-5971](https://insights.sbomify.com/CVE-2026-5971/): FoundationAgents MetaGPT XML action_node.py ActionNode.xml_fill eval injection (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23750 and fix it if it is affected.

What it is: CVE-2024-23750 is a high-severity command injection vulnerability in n/a, published on 22 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23750 exists.

Affected packages and fixed versions:
- metagpt (PyPI): affected all versions up to 0.6.6; no fix listed
- metagpt (PyPI): affected all versions up to 0.6.6; no fix listed
- metagpt (PyPI): affected all versions; fixed in 0.6.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23750/ (Markdown: https://insights.sbomify.com/CVE-2024-23750/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23750
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23750
- OSV: https://osv.dev/vulnerability/CVE-2024-23750

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23750/
Summaries are generated and may contain mistakes; the official description above is the record.
