# CVE-2024-23807: Apache Xerces C++: Use-after-free on external DTD scan

> A use-after-free vulnerability in the Apache Xerces C++ XML parser allows attackers to execute arbitrary code or cause denial of service via malicious external DTDs.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Feb 2024
- **Updated:** 22 Jan 2026
- **Also known as:** AZL-55883, AZL-55898, ECHO-ae39-d338-5e8a, GHSA-8582-h585-f568, UBUNTU-CVE-2024-23807

## What is CVE-2024-23807?

CVE-2024-23807 is a high-severity use after free vulnerability in Apache Xerces C++, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Xerces C++ XML parser on versions 3.0.0 before 3.2.5 contains a use-after-free error triggered during the scanning of external DTDs.

Users are recommended to upgrade to version 3.2.5 which fixes the issue, or mitigate the issue by disabling DTD processing. This can be accomplished via the DOM using a standard parser feature, or via SAX using the XERCES_DISABLE_DTD environment variable.

This issue has been disclosed before as CVE-2018-1311, but unfortunately that advisory incorrectly stated the issue would be fixed in version 3.2.3 or 3.2.4.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2024-23807?

It affects 1 product.


Products: Apache Xerces-C\+\+.

## How do I fix CVE-2024-23807?

Upgrade to a fixed version.

## Is CVE-2024-23807 being exploited?

There is no known exploitation of CVE-2024-23807 in the wild and no public exploit code.

## Other vulnerabilities in Apache Xerces C++

- [CVE-2017-12627](https://insights.sbomify.com/CVE-2017-12627/): Null dereference in Apache Xerces C++ (critical 9.8)
- [CVE-2016-2099](https://insights.sbomify.com/CVE-2016-2099/): Use after free in n/a (critical 9.8)
- [CVE-2023-37536](https://insights.sbomify.com/CVE-2023-37536/): HCL BigFix Platform is vulnerable to an integer overflow in xerces-c++ 3.2.3 (high 8.2)
- [CVE-2018-1311](https://insights.sbomify.com/CVE-2018-1311/): Use after free in Apache Xerces-C (high 8.1)
- [CVE-2008-4482](https://insights.sbomify.com/CVE-2008-4482/): Denial of service in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23807 and fix it if it is affected.

What it is: CVE-2024-23807 is a high-severity use after free vulnerability in Apache Xerces C++, published on 28 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23807 in the wild and no public exploit code.

Affected product: Apache Xerces C++. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23807/ (Markdown: https://insights.sbomify.com/CVE-2024-23807/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23807
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23807
- OSV: https://osv.dev/vulnerability/CVE-2024-23807

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23807/
Summaries are generated and may contain mistakes; the official description above is the record.
