# CVE-2024-23817: Dolibarr Application Home Page HTML injection vulnerability

> Attackers can inject HTML into the Dolibarr home page, potentially leading to Cross-Site Scripting (XSS) and content manipulation.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jan 2024
- **Updated:** 17 Jun 2025
- **Also known as:** BIT-dolibarr-2024-23817, GHSA-7947-48q7-cp5m, UBUNTU-CVE-2024-23817

## What is CVE-2024-23817?

CVE-2024-23817 is a high-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 25 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Dolibarr is an enterprise resource planning (ERP) and customer relationship management (CRM) software package. Version 18.0.4 has a HTML Injection vulnerability in the Home page of the Dolibarr Application. This vulnerability allows an attacker to inject arbitrary HTML tags and manipulate the rendered content in the application's response. Specifically, I was able to successfully inject a new HTML tag into the returned document and, as a result, was able to comment out some part of the Dolibarr App Home page HTML code. This behavior can be exploited to perform various attacks like Cross-Site Scripting (XSS). To remediate the issue, validate and sanitize all user-supplied input, especially within HTML attributes, to prevent HTML injection attacks; and implement proper output encoding when rendering user-provided data to ensure it is treated as plain text rather than executable HTML.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23817?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 18.0.4 | 18.0.7 |
| `dolibarr/dolibarr` | Packagist | From 18.0.4 | 18.0.7 |
| `dolibarr` | Bitnami | From 18.0.4 | 18.0.5 |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2024-23817?

Upgrade dolibarr/dolibarr to 18.0.7 or later.

## Is CVE-2024-23817 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23817 exists.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23817 and fix it if it is affected.

What it is: CVE-2024-23817 is a high-severity cross-site scripting vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 25 Jan 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23817 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 18.0.4; fixed in 18.0.7
- dolibarr/dolibarr (Packagist): affected from 18.0.4; fixed in 18.0.7
- dolibarr (Bitnami): affected from 18.0.4; fixed in 18.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23817/ (Markdown: https://insights.sbomify.com/CVE-2024-23817/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23817
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23817
- OSV: https://osv.dev/vulnerability/CVE-2024-23817

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23817/
Summaries are generated and may contain mistakes; the official description above is the record.
