CVE-2024-23819 GeoServer Stored Cross-Site Scripting (XSS) vulnerability in MapML HTML Page

Medium 4.8 Published Updated

An authenticated administrator can inject JavaScript into GeoServer's MapML page, executing code in other users' browsers.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2024-23819?

CVE-2024-23819 is a medium-severity cross-site scripting vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.

Weakness: CWE-79

Which versions are affected by CVE-2024-23819?

4 open source packages ship an affected version, including org.geoserver.extension:gs-mapml. It affects 1 product.

PackageAffectedFixed in
org.geoserver.extension:gs-mapml MavenAll versions2.23.4
org.geoserver.extension:gs-mapml MavenAll versions2.23.4
org.geoserver.extension:gs-mapml MavenFrom 2.24.02.24.1
org.geoserver.extension:gs-mapml MavenFrom 2.24.02.24.1

Products include Geoserver Geoserver.

How do I fix CVE-2024-23819?

Upgrade org.geoserver.extension:gs-mapml to a fixed version for your release line: 2.23.4 or 2.24.1.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2024-23819 being exploited?

There is no known exploitation of CVE-2024-23819 in the wild and no public exploit code.

Sources

Also known as GHSA-7x76-57fr-m5r5.

Is CVE-2024-23819 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free