{"answers":{"affected":"4 open source packages ship an affected version, including org.geoserver.extension:gs-mapml. It affects 1 product.","exploited":"There is no known exploitation of CVE-2024-23819 in the wild and no public exploit code.","fix":"Upgrade org.geoserver.extension:gs-mapml to a fixed version for your release line: 2.23.4 or 2.24.1.","what":"CVE-2024-23819 is a medium-severity cross-site scripting vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-23819 and fix it if it is affected.\n\nWhat it is: CVE-2024-23819 is a medium-severity cross-site scripting vulnerability in geoserver, published on 20 Mar 2024. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2024-23819 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.geoserver.extension:gs-mapml (Maven): affected all versions; fixed in 2.23.4\n- org.geoserver.extension:gs-mapml (Maven): affected all versions; fixed in 2.23.4\n- org.geoserver.extension:gs-mapml (Maven): affected from 2.24.0; fixed in 2.24.1\n- org.geoserver.extension:gs-mapml (Maven): affected from 2.24.0; fixed in 2.24.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-23819/ (Markdown: https://insights.sbomify.com/CVE-2024-23819/index.md)","id":"CVE-2024-23819","markdown":"https://insights.sbomify.com/CVE-2024-23819/index.md","name":"CVE-2024-23819","record":{"aliases":["GHSA-7x76-57fr-m5r5"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"GeoServer","requires_auth":"high_privilege","summary":"An authenticated administrator can inject JavaScript into GeoServer's MapML page, executing code in other users' browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"geoserver","vendor":"geoserver"}],"cvss":{"score":4.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. A stored cross-site scripting (XSS) vulnerability exists in versions prior to 2.23.4 and 2.24.1 that enables an authenticated administrator with workspace-level privileges to store a JavaScript payload in the GeoServer catalog that will execute in the context of another user's browser when viewed in the MapML HTML Page. The MapML extension must be installed and access to the MapML HTML Page is available to all users although data security may limit users' ability to trigger the XSS. Versions 2.23.4 and 2.24.1 contain a patch for this issue.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"GeoServer Stored Cross-Site Scripting (XSS) vulnerability in MapML HTML Page","id":"CVE-2024-23819","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2024"},"n_packages":4,"n_references":5,"next":{"headline":"OpenFGA DoS","id":"CVE-2024-23820"},"packages":[{"ecosystem":"Maven","fixed":["2.23.4"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.extension:gs-mapml","purl":null,"source":"GHSA-7x76-57fr-m5r5"},{"ecosystem":"Maven","fixed":["2.23.4"],"introduced":["0"],"last_affected":[],"package":"org.geoserver.extension:gs-mapml","purl":"pkg:maven/org.geoserver.extension/gs-mapml","source":"GHSA-7x76-57fr-m5r5"},{"ecosystem":"Maven","fixed":["2.24.1"],"introduced":["2.24.0"],"last_affected":[],"package":"org.geoserver.extension:gs-mapml","purl":null,"source":"GHSA-7x76-57fr-m5r5"},{"ecosystem":"Maven","fixed":["2.24.1"],"introduced":["2.24.0"],"last_affected":[],"package":"org.geoserver.extension:gs-mapml","purl":"pkg:maven/org.geoserver.extension/gs-mapml","source":"GHSA-7x76-57fr-m5r5"}],"prev":{"headline":"GeoServer Stored Cross-Site Scripting (XSS) vulnerability in WMS OpenLayers Format","id":"CVE-2024-23818"},"products":["geoserver"],"published":"2024-03-20","related":[{"cvss_score":9.8,"headline":"OSGeo GeoServer GeoTools Eval Injection","id":"CVE-2024-36401","kev_date_added":"2024-07-15","published":"2024-07-01"},{"cvss_score":8.2,"headline":"OSGeo GeoServer Improper Restriction of XML External Entity Reference","id":"CVE-2025-58360","kev_date_added":"2025-12-11","published":"2025-11-25"},{"cvss_score":9.8,"headline":"GeoServer RCE due to improper control of generation of code in jai-ext`Jiffle` map algebra language","id":"CVE-2023-35042","kev_date_added":null,"published":"2023-06-12"},{"cvss_score":7.5,"headline":"Classpath resource disclosure in GWC Web Resource API on Windows / Tomcat","id":"CVE-2024-24749","kev_date_added":null,"published":"2024-07-01"},{"cvss_score":7.2,"headline":"GeoServer log file path traversal vulnerability","id":"CVE-2023-41877","kev_date_added":null,"published":"2024-03-20"},{"cvss_score":7.2,"headline":"GeoServer arbitrary file upload vulnerability in REST Coverage Store API","id":"CVE-2023-51444","kev_date_added":null,"published":"2024-03-20"},{"cvss_score":6.1,"headline":"GeoServer Reflected Cross-Site Scripting (XSS) vulnerability in WMS GetFeatureInfo HTML format","id":"CVE-2025-21621","kev_date_added":null,"published":"2025-11-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["geoserver"]},"summary":"An authenticated administrator can inject JavaScript into GeoServer's MapML page, executing code in other users' browsers.","url":"https://insights.sbomify.com/CVE-2024-23819/"}