# CVE-2024-23823: CORS settings overly permissive in vantage6

> The vantage6 server lacks CORS restrictions, potentially allowing unauthorized cross-origin requests, though impact is limited by lack of session cookies.

- **Severity:** Medium 4.2 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Mar 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-4946-85pr-fvxh, PYSEC-2024-326, PYSEC-2026-2004

## What is CVE-2024-23823?

CVE-2024-23823 is a medium-severity vulnerability in vantage6, published on 14 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. The vantage6 server has no restrictions on CORS settings. It should be possible for people to set the allowed origins of the server.  The impact is limited because v6 does not use session cookies. This issue has been addressed in commit `70bb4e1d8` and is expected to ship in subsequent releases. Users are advised to upgrade as soon as a new release is available. There are no known workarounds for this vulnerability.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2024-23823?

4 open source packages ship an affected version, including vantage6 and vantage6-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vantage6` | PyPI | All versions | 4.3.0 |
| `vantage6` | PyPI | All versions | 4.3.0 |
| `vantage6` | PyPI | All versions | 4.3.0 |
| `vantage6-server` | PyPI | All versions | 4.2.1 |

Products: Vantage6 Vantage6.

## How do I fix CVE-2024-23823?

Upgrade vantage6 to 4.3.0 or later.

## Is CVE-2024-23823 being exploited?

There is no known exploitation of CVE-2024-23823 in the wild and no public exploit code.

## Other vulnerabilities in vantage6

- [CVE-2024-21649](https://insights.sbomify.com/CVE-2024-21649/): Remote code execution (high 8.8)
- [CVE-2023-23929](https://insights.sbomify.com/CVE-2023-23929/): Refresh tokens do not expire in Vantage6 (high 8.8)
- [CVE-2023-47631](https://insights.sbomify.com/CVE-2023-47631/): vantage6 Node accepts non-whitelisted algorithms from malicious server (high 7.2)
- [CVE-2024-21653](https://insights.sbomify.com/CVE-2024-21653/): vantage6 insecure SSH configuration for node and server containers (medium 6.5)
- [CVE-2023-22738](https://insights.sbomify.com/CVE-2023-22738/): Improper Preservation of Permissions in vantage6 (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23823 and fix it if it is affected.

What it is: CVE-2024-23823 is a medium-severity vulnerability in vantage6, published on 14 Mar 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23823 in the wild and no public exploit code.

Affected packages and fixed versions:
- vantage6 (PyPI): affected all versions; fixed in 4.3.0
- vantage6 (PyPI): affected all versions; fixed in 4.3.0
- vantage6 (PyPI): affected all versions; fixed in 4.3.0
- vantage6-server (PyPI): affected all versions; fixed in 4.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23823/ (Markdown: https://insights.sbomify.com/CVE-2024-23823/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23823
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23823
- OSV: https://osv.dev/vulnerability/CVE-2024-23823

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23823/
Summaries are generated and may contain mistakes; the official description above is the record.
