# CVE-2024-23825: TablePress SSRF vulnerability due to insufficient filtering of cloud provider hosts

> An attacker can exploit insufficient URL filtering in TablePress to perform Server-Side Request Forgery, potentially exposing cloud instance metadata and credentials.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 30 Jan 2024
- **Updated:** 29 May 2025
- **Also known as:** GHSA-x8rf-c8x6-mrpg

## What is CVE-2024-23825?

CVE-2024-23825 is a low-severity server-side request forgery vulnerability in TablePress, published on 30 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

TablePress is a table plugin for Wordpress. For importing tables, TablePress makes external HTTP requests based on a URL that is provided by the user. That user input is filtered insufficiently, which makes it is possible to send requests to unintended network locations and receive responses. On sites in a cloud environment like AWS, an attacker can potentially make GET requests to the instance's metadata REST API. If the instance's configuration is insecure, this can lead to the exposure of internal data, including credentials. This vulnerability is fixed in 2.2.5.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2024-23825?

It affects 1 product.


Products: Tablepress Tablepress.

## How do I fix CVE-2024-23825?

No fix has been published for CVE-2024-23825 yet. Limit exposure of the affected software until one is available.

## Is CVE-2024-23825 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23825 exists.

## Other vulnerabilities in TablePress

- [CVE-2019-20180](https://insights.sbomify.com/CVE-2019-20180/): Other in n/a (medium 6.8)
- [CVE-2025-5096](https://insights.sbomify.com/CVE-2025-5096/): TablePress <= 3.1.2 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Multiple Parameters (medium 6.4)
- [CVE-2025-2685](https://insights.sbomify.com/CVE-2025-2685/): TablePress – Tables in WordPress made easy <= 3.0.4 - Authenticated (Author+) Stored Cross-Site Scripting (medium 6.4)
- [CVE-2024-9595](https://insights.sbomify.com/CVE-2024-9595/): TablePress <= 2.4.2 - Authenticated (Author+) Stored Cross-Site Scripting (medium 6.4)
- [CVE-2024-4354](https://insights.sbomify.com/CVE-2024-4354/): TablePress – Tables in WordPress made easy <= 2.3 - Authenticated (Author+) Server-Side Request Forgery via DNS Rebind (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23825 and fix it if it is affected.

What it is: CVE-2024-23825 is a low-severity server-side request forgery vulnerability in TablePress, published on 30 Jan 2024. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-23825 exists.

Affected product: TablePress. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23825/ (Markdown: https://insights.sbomify.com/CVE-2024-23825/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23825
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23825
- OSV: https://osv.dev/vulnerability/CVE-2024-23825

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23825/
Summaries are generated and may contain mistakes; the official description above is the record.
