# CVE-2024-23829: aiohttp's HTTP parser (the python one, not llhttp) still overly lenient about separators

> Attackers can cause denial of service via unhandled exceptions or potentially bypass security controls through request smuggling due to lenient HTTP parsing.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2024
- **Updated:** 3 Nov 2025
- **Also known as:** AZL-43774, AZL-45189, CLSA-2026-1768349585, DEBIAN-CVE-2024-23829, ECHO-e8ca-86bc-10b8, GHSA-8qpw-xqxj-h4r2, PYSEC-2024-26, ROOT-APP-PYPI-CVE-2024-23829, UBUNTU-CVE-2024-23829

## What is CVE-2024-23829?

CVE-2024-23829 is a medium-severity vulnerability in Fedoraproject Fedora, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. Security-sensitive parts of the Python HTTP parser retained minor differences in allowable character sets, that must trigger error handling to robustly match frame boundaries of proxies in order to protect against injection of additional requests. Additionally, validation could trigger exceptions that were not handled consistently with processing of other malformed input.  Being more lenient than internet standards require could, depending on deployment environment, assist in request smuggling. The unhandled exception could cause excessive resource consumption on the application server and/or its logging facilities. This vulnerability exists due to an incomplete fix for CVE-2023-47627. Version 3.9.2 fixes this vulnerability.

Weakness: CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2024-23829?

3 open source packages ship an affected version, including aiohttp. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp` | PyPI | All versions | 3.9.2 |
| `aiohttp` | PyPI | All versions | 3.9.2 |
| `aiohttp` | PyPI | All versions | 3.9.2 |

Products: Aiohttp Aiohttp, Fedoraproject Fedora.

## How do I fix CVE-2024-23829?

Upgrade aiohttp to 3.9.2 or later.

## Is CVE-2024-23829 being exploited?

There is no known exploitation of CVE-2024-23829 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-52303](https://insights.sbomify.com/CVE-2024-52303/): aiohttp memory leak when middleware is enabled when requesting a resource with a non-allowed method (high 8.7)
- [CVE-2025-69223](https://insights.sbomify.com/CVE-2025-69223/): AIOHTTP's HTTP Parser auto_decompress feature is vulnerable to zip bomb (high 7.5)
- [CVE-2024-30251](https://insights.sbomify.com/CVE-2024-30251/): Denial of service when trying to parse malformed POST requests in aiohttp (high 7.5)
- [CVE-2023-49081](https://insights.sbomify.com/CVE-2023-49081/): aiohttp's ClientSession is vulnerable to CRLF injection via version (high 7.2)
- [CVE-2026-22815](https://insights.sbomify.com/CVE-2026-22815/): AIOHTTP: Uncapped memory usage possible through aiohttp allowing unlimited trailer headers (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23829 and fix it if it is affected.

What it is: CVE-2024-23829 is a medium-severity vulnerability in Fedoraproject Fedora, published on 29 Jan 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23829 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp (PyPI): affected all versions; fixed in 3.9.2
- aiohttp (PyPI): affected all versions; fixed in 3.9.2
- aiohttp (PyPI): affected all versions; fixed in 3.9.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23829/ (Markdown: https://insights.sbomify.com/CVE-2024-23829/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23829
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23829
- OSV: https://osv.dev/vulnerability/CVE-2024-23829

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23829/
Summaries are generated and may contain mistakes; the official description above is the record.
