{"answers":{"affected":"3 open source packages ship an affected version, including zenml. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2383 exists.","fix":"Upgrade zenml to 0.56.3 or later.","what":"CVE-2024-2383 is a medium-severity vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2024-2383 and fix it if it is affected.\n\nWhat it is: CVE-2024-2383 is a medium-severity vulnerability in zenml-io/zenml, published on 6 Jun 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2024-2383 exists.\n\nAffected packages and fixed versions:\n- zenml (PyPI): affected all versions; fixed in 0.56.3\n- zenml (PyPI): affected all versions; fixed in 0.56.3\n- zenml (PyPI): affected all versions; fixed in 0.56.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2024-2383/ (Markdown: https://insights.sbomify.com/CVE-2024-2383/index.md)","id":"CVE-2024-2383","markdown":"https://insights.sbomify.com/CVE-2024-2383/index.md","name":"CVE-2024-2383","record":{"aliases":["GHSA-mq73-g4qr-fgcq","PYSEC-2024-194"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"ZenML MLOps platform","requires_auth":"none","summary":"Attackers can embed the ZenML UI in iframes to trick users into performing unauthorized actions due to missing security headers.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[{"product":"zenml","vendor":"zenml"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-1021","name":"Improper Restriction of Rendered UI Layers or Frames"}],"description":"A clickjacking vulnerability exists in zenml-io/zenml versions up to and including 0.55.5 due to the application's failure to set appropriate X-Frame-Options or Content-Security-Policy HTTP headers. This vulnerability allows an attacker to embed the application UI within an iframe on a malicious page, potentially leading to unauthorized actions by tricking users into interacting with the interface under the attacker's control. The issue was addressed in version 0.56.3.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Clickjacking Vulnerability in zenml-io/zenml","id":"CVE-2024-2383","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"csrf","year":"2024"},"n_packages":3,"n_references":2,"next":{"headline":"Missing authorization in WCPOS – Point of Sale (POS) plugin for WooCommerce","id":"CVE-2024-2384"},"packages":[{"ecosystem":"PyPI","fixed":["0.56.3"],"introduced":["0"],"last_affected":[],"package":"zenml","purl":null,"source":"GHSA-mq73-g4qr-fgcq"},{"ecosystem":"PyPI","fixed":["0.56.3"],"introduced":["0"],"last_affected":[],"package":"zenml","purl":"pkg:pypi/zenml","source":"GHSA-mq73-g4qr-fgcq"},{"ecosystem":"PyPI","fixed":["0.56.3"],"introduced":["0"],"last_affected":[],"package":"zenml","purl":"pkg:pypi/zenml","source":"PYSEC-2024-194"}],"prev":{"headline":"Business logic in Authorize.net Payment Gateway For WooCommerce","id":"CVE-2024-2382"},"products":["zenml-io/zenml"],"published":"2024-06-06","related":[{"cvss_score":9.9,"headline":"Directory Traversal in zenml-io/zenml","id":"CVE-2024-2083","kev_date_added":null,"published":"2024-04-16"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2024-28424","kev_date_added":null,"published":"2024-03-14"},{"cvss_score":8.8,"headline":"ZenML Server Remote Privilege Escalation Vulnerability","id":"CVE-2024-25723","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"Denial of Service (DoS) via Multipart Boundary in zenml-io/zenml","id":"CVE-2024-9340","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":6.5,"headline":"Improper Authorization in zenml-io/zenml","id":"CVE-2024-2035","kev_date_added":null,"published":"2024-06-06"},{"cvss_score":6.3,"headline":"Path Traversal in zenml-io/zenml","id":"CVE-2025-8406","kev_date_added":null,"published":"2025-10-05"},{"cvss_score":5.4,"headline":"Lack of login attempt rate-limiting in zenml-io/zenml","id":"CVE-2024-4311","kev_date_added":null,"published":"2024-11-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2024-08-01","vendors":["zenml-io"]},"summary":"Attackers can embed the ZenML UI in iframes to trick users into performing unauthorized actions due to missing security headers.","url":"https://insights.sbomify.com/CVE-2024-2383/"}