# CVE-2024-23830: MantisBT Host Header Injection vulnerability

> An attacker can hijack user accounts by poisoning password reset links via Host Header Injection in MantisBT.

- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Feb 2024
- **Updated:** 1 Aug 2024
- **Also known as:** GHSA-mcqj-7p29-9528

## What is CVE-2024-23830?

CVE-2024-23830 is a high-severity vulnerability in Mantisbt Mantisbt, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MantisBT is an open source issue tracker. Prior to version 2.26.1, an unauthenticated attacker who knows a user's email address and username can hijack the user's account by poisoning the link in the password reset notification message. A patch is available in version 2.26.1. As a workaround, define `$g_path` as appropriate in `config_inc.php`.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2024-23830?

2 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.1 |
| `mantisbt/mantisbt` | Packagist | All versions | 2.26.1 |

Products: Mantisbt Mantisbt.

## How do I fix CVE-2024-23830?

Upgrade mantisbt/mantisbt to 2.26.1 or later.

## Is CVE-2024-23830 being exploited?

There is no known exploitation of CVE-2024-23830 in the wild and no public exploit code.

## Other vulnerabilities in Mantisbt Mantisbt

- [CVE-2019-15074](https://insights.sbomify.com/CVE-2019-15074/): MantisBT allows cross-site scripting (XSS) via crafted filename (critical 9.6)
- [CVE-2026-30849](https://insights.sbomify.com/CVE-2026-30849/): MantisBT SOAP API has an authentication bypass vulnerability on MySQL (critical 9.3)
- [CVE-2025-47776](https://insights.sbomify.com/CVE-2025-47776/): MantisBT: Authentication bypass for some passwords due to PHP type juggling (high 8.8)
- [CVE-2017-7615](https://insights.sbomify.com/CVE-2017-7615/): MantisBT allows arbitrary password reset (high 8.8)
- [CVE-2026-33517](https://insights.sbomify.com/CVE-2026-33517/): MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation (high 8.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23830 and fix it if it is affected.

What it is: CVE-2024-23830 is a high-severity vulnerability in Mantisbt Mantisbt, published on 20 Feb 2024. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2024-23830 in the wild and no public exploit code.

Affected packages and fixed versions:
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.1
- mantisbt/mantisbt (Packagist): affected all versions; fixed in 2.26.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23830/ (Markdown: https://insights.sbomify.com/CVE-2024-23830/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23830
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23830
- OSV: https://osv.dev/vulnerability/CVE-2024-23830

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23830/
Summaries are generated and may contain mistakes; the official description above is the record.
