CVE-2024-23832 Mastodon Remote user impersonation and takeover

Critical 9.4 Published Updated

Attackers can impersonate and take over remote accounts due to insufficient origin validation in Mastodon server software.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2024-23832?

CVE-2024-23832 is a critical authentication bypass vulnerability in mastodon, published on 1 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Mastodon is a free, open-source social network server based on ActivityPub Mastodon allows configuration of LDAP for authentication. Due to insufficient origin validation in all Mastodon, attackers can impersonate and take over any remote account. Every Mastodon version prior to 3.5.17 is vulnerable, as well as 4.0.x versions prior to 4.0.13, 4.1.x version prior to 4.1.13, and 4.2.x versions prior to 4.2.5.

Weakness: CWE-290

Which versions are affected by CVE-2024-23832?

1 open source package ship an affected version, including mastodon. It affects 1 product.

PackageAffectedFixed in
mastodon BitnamiAll versions3.5.17, 4.0.13, 4.1.13, 4.2.5

Products include Joinmastodon Mastodon.

How do I fix CVE-2024-23832?

Upgrade mastodon to a fixed version for your release line: 3.5.17, 4.0.13, 4.1.13 or 4.2.5.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2024-23832 being exploited?

There is no known exploitation of CVE-2024-23832 in the wild and no public exploit code.

Sources

Also known as BIT-mastodon-2024-23832, GHSA-3fjr-858r-92rw.

Is CVE-2024-23832 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free