# CVE-2024-23832: Mastodon Remote user impersonation and takeover

> Attackers can impersonate and take over remote accounts due to insufficient origin validation in Mastodon server software.

- **Severity:** Critical 9.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** BIT-mastodon-2024-23832, GHSA-3fjr-858r-92rw

## What is CVE-2024-23832?

CVE-2024-23832 is a critical authentication bypass vulnerability in mastodon, published on 1 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mastodon is a free, open-source social network server based on ActivityPub Mastodon allows configuration of LDAP for authentication. Due to insufficient origin validation in all Mastodon, attackers can impersonate and take over any remote account. Every Mastodon version prior to 3.5.17 is vulnerable, as well as 4.0.x versions prior to 4.0.13, 4.1.x version prior to 4.1.13, and 4.2.x versions prior to 4.2.5.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2024-23832?

1 open source package ship an affected version, including mastodon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mastodon` | Bitnami | All versions | 3.5.17, 4.0.13, 4.1.13, 4.2.5 |

Products: Joinmastodon Mastodon.

## How do I fix CVE-2024-23832?

Upgrade mastodon to a fixed version for your release line: 3.5.17, 4.0.13, 4.1.13 or 4.2.5.

## Is CVE-2024-23832 being exploited?

There is no known exploitation of CVE-2024-23832 in the wild and no public exploit code.

## Other vulnerabilities in mastodon

- [CVE-2023-36460](https://insights.sbomify.com/CVE-2023-36460/): Mastodon vulnerable to arbitrary file creation through media attachments (critical 10.0)
- [CVE-2022-2166](https://insights.sbomify.com/CVE-2022-2166/): Improper Restriction of Excessive Authentication Attempts in mastodon/mastodon (critical 9.8)
- [CVE-2022-24307](https://insights.sbomify.com/CVE-2022-24307/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-21018](https://insights.sbomify.com/CVE-2018-21018/): Auth bypass in n/a (critical 9.8)
- [CVE-2023-36459](https://insights.sbomify.com/CVE-2023-36459/): Mastodon vulnerable to Cross-site Scripting through oEmbed preview cards (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23832 and fix it if it is affected.

What it is: CVE-2024-23832 is a critical authentication bypass vulnerability in mastodon, published on 1 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23832 in the wild and no public exploit code.

Affected packages and fixed versions:
- mastodon (Bitnami): affected all versions; fixed in 3.5.17, 4.0.13, 4.1.13, 4.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23832/ (Markdown: https://insights.sbomify.com/CVE-2024-23832/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23832
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23832
- OSV: https://osv.dev/vulnerability/CVE-2024-23832

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23832/
Summaries are generated and may contain mistakes; the official description above is the record.
