# CVE-2024-23833: OpenRefine JDBC Attack Vulnerability

> An attacker can exploit a JDBC vulnerability in OpenRefine to read sensitive files from the host filesystem.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2024
- **Updated:** 7 May 2025
- **Also known as:** DEBIAN-CVE-2024-23833, GHSA-6p92-qfqf-qwx4, UBUNTU-CVE-2024-23833

## What is CVE-2024-23833?

CVE-2024-23833 is a high-severity path traversal vulnerability in OpenRefine, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenRefine is a free, open source power tool for working with messy data and improving it. A jdbc attack vulnerability exists in OpenRefine(version<=3.7.7) where an attacker may construct a JDBC query which may read files on the host filesystem. Due to the newer MySQL driver library in the latest version of OpenRefine (8.0.30), there is no associated deserialization utilization point, so original code execution cannot be achieved, but attackers can use this vulnerability to read sensitive files on the target server. This issue has been addressed in version 3.7.8. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-863 (Incorrect Authorization), CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2024-23833?

2 open source packages ship an affected version, including org.openrefine:database. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.openrefine:database` | Maven | All versions | 3.7.8 |
| `org.openrefine:database` | Maven | All versions | 3.7.8 |

Products: Openrefine Openrefine.

## How do I fix CVE-2024-23833?

Upgrade org.openrefine:database to 3.7.8 or later.

## Is CVE-2024-23833 being exploited?

There is no known exploitation of CVE-2024-23833 in the wild and no public exploit code.

## Other vulnerabilities in OpenRefine

- [CVE-2023-41887](https://insights.sbomify.com/CVE-2023-41887/): Remote Code exec in project import with mysql jdbc url attack (critical 9.8)
- [CVE-2024-47878](https://insights.sbomify.com/CVE-2024-47878/): Reflected cross-site scripting vulnerability (XSS) in GData extension (authorized.vt) (high 8.1)
- [CVE-2024-47880](https://insights.sbomify.com/CVE-2024-47880/): OpenRefine has a reflected cross-site scripting vulnerability from POST request in ExportRowsCommand (high 8.1)
- [CVE-2024-47881](https://insights.sbomify.com/CVE-2024-47881/): OpenRefine's SQLite integration allows filesystem access, remote code execution (RCE) (high 8.1)
- [CVE-2024-47879](https://insights.sbomify.com/CVE-2024-47879/): OpenRefine's PreviewExpressionCommand, which is eval, lacks protection against cross-site request forgery (CSRF) (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23833 and fix it if it is affected.

What it is: CVE-2024-23833 is a high-severity path traversal vulnerability in OpenRefine, published on 12 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23833 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.openrefine:database (Maven): affected all versions; fixed in 3.7.8
- org.openrefine:database (Maven): affected all versions; fixed in 3.7.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23833/ (Markdown: https://insights.sbomify.com/CVE-2024-23833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23833
- OSV: https://osv.dev/vulnerability/CVE-2024-23833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23833/
Summaries are generated and may contain mistakes; the official description above is the record.
