# CVE-2024-23834: Discourse improperly sanitized user input leads to XSS

> Attackers can execute arbitrary scripts in Discourse forums if Content Security Policy is disabled, potentially compromising user accounts.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2024
- **Updated:** 17 Oct 2024
- **Also known as:** BIT-discourse-2024-23834, GHSA-rj3g-8q6p-63pc

## What is CVE-2024-23834?

CVE-2024-23834 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 30 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Discourse is an open-source discussion platform. Improperly sanitized user input could lead to an XSS vulnerability in some situations. This vulnerability only affects Discourse instances which have disabled the default Content Security Policy. The vulnerability is patched in 3.1.5 and 3.2.0.beta5.  As a workaround, ensure Content Security Policy is enabled and does not include `unsafe-inline`.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2024-23834?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 3.2.0 |

Products: Discourse Discourse.

## How do I fix CVE-2024-23834?

Upgrade discourse to 3.2.0 or later.

## Is CVE-2024-23834 being exploited?

There is no known exploitation of CVE-2024-23834 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23834 and fix it if it is affected.

What it is: CVE-2024-23834 is a medium-severity cross-site scripting vulnerability in Discourse Discourse, published on 30 Jan 2024. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23834 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23834/ (Markdown: https://insights.sbomify.com/CVE-2024-23834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23834
- OSV: https://osv.dev/vulnerability/CVE-2024-23834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23834/
Summaries are generated and may contain mistakes; the official description above is the record.
