# CVE-2024-23835: Suricata's pgsql: memory exhaustion use on record parsing

> Attackers can cause denial of service in Suricata by triggering excessive memory usage during PostgreSQL protocol parsing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Feb 2024
- **Updated:** 13 Feb 2025
- **Also known as:** DEBIAN-CVE-2024-23835, GHSA-8583-353f-mvwc, UBUNTU-CVE-2024-23835

## What is CVE-2024-23835?

CVE-2024-23835 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Suricata is a network Intrusion Detection System, Intrusion Prevention System and Network Security Monitoring engine.  Prior to version 7.0.3, excessive memory use during pgsql parsing could lead to OOM-related crashes.  This vulnerability is patched in 7.0.3.  As workaround, users can disable the pgsql app layer parser.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2024-23835?

It affects 2 products.


Products: Fedoraproject Fedora, Oisf Suricata.

## How do I fix CVE-2024-23835?

Upgrade to a fixed version.

## Is CVE-2024-23835 being exploited?

There is no known exploitation of CVE-2024-23835 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2024-23835 and fix it if it is affected.

What it is: CVE-2024-23835 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 26 Feb 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2024-23835 in the wild and no public exploit code.

Affected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2024-23835/ (Markdown: https://insights.sbomify.com/CVE-2024-23835/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2024-23835
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2024-23835
- OSV: https://osv.dev/vulnerability/CVE-2024-23835

---
From sbomify Insights: https://insights.sbomify.com/CVE-2024-23835/
Summaries are generated and may contain mistakes; the official description above is the record.
